Winter Scripting Games 2014 Tip #2: Use #Requires to let PowerShell do the work for you

In Version 2 of PowerShell, you had the ability to use #Requires –Version 2.0 to ensure that your scripts/functions would only run at a specified PowerShell version to prevent folks running an older version from wondering why things weren't working that well.

In this article, I will show you a couple of new additions to the #Requires statement that will make your life easier when writing functions that require specific pre-requisites rather than coding your own methods

Click here to be redirected to the original post of this article on the author’s blog site where you can read the remainder of the article..

Posted in: