A Problem with unzipping resource pulled from server

Welcome Forums DSC (Desired State Configuration) A Problem with unzipping resource pulled from server

This topic contains 1 reply, has 2 voices, and was last updated by

 
Keymaster
2 years, 2 months ago.

  • Author
    Posts
  • #59398

    Participant
    Points: 0
    Rank: Member

    Hello Everyone!

    I have encountered a problem while applying configuration that uses SQLServer resource which is pulled form pull server.

    The events are these:

    Desired State Configuration id 4250
    {2FD08E03-BAED-11E6-80C6-000C29492C0D}
    Access to the path 'C:\Program Files\WindowsPowerShell\Modules\xSQLServer\3.0.0.0' is denied.
    -2147024891
    at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
    at System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy, Boolean useLongPath, Boolean checkHost)
    at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share)
    at System.IO.Compression.ZipFileExtensions.ExtractToFile(ZipArchiveEntry source, String destinationFileName, Boolean overwrite)
    at Microsoft.PowerShell.DesiredStateConfiguration.Internal.DownloadManagerBase.ValidateAndInstallOneModule(String downloadLocation, ModuleSpecification moduleSpecification, ModuleSpecification requiredModuleSpecification, IEnumerable`1 requiredResources, Boolean allowModuleOverwrite, IStreamsHandler plugInStreamsHandler, ErrorRecord& errorRecord, UInt32& getActionStatusCode)


    Desired State Configuration id 4104
    {2FD08E03-BAED-11E6-80C6-000C29492C0D}
    LCM
    NULL
    1
    Failed to extract the module from zip file C:\Windows\TEMP\\636165514603628999\xSQLServer_3.0.0.0.zip downloaded by Download Manager WebDownloadManager.

    I tried to give full access for anyone to the folder C:\Program Files\WindowsPowerShell\Modules\xSQLServer but there was no use I also tried to patch my system with latest updates but again no benefit. Guys, what could it be?

  • #59544

    Keymaster
    Points: 1,811
    Helping HandTeam Member
    Rank: Community Hero

    I almost suspect the permissions on /Modules/, or higher, are preventing the LCM from writing files.

The topic ‘A Problem with unzipping resource pulled from server’ is closed to new replies.

denizli escort samsun escort muğla escort ataşehir escort kuşadası escort