Author Posts

April 2, 2017 at 7:58 am

Not able to run get-dscconfiguration.
Getting the following error:
PS C:\WINDOWS\system32> Get-DscConfiguration
WARNING: [NARINDERVERMA]: [] The GET operation will be carried against a pending configuration since the la
test configuration has not converged yet.
Get-DscConfiguration : PowerShell DSC resource MSFT_RoleResource failed to execute Get-TargetResource functionality with error
message: Installing roles and features using PowerShell Desired State Configuration is supported only on Server SKU's. It is not
supported on Client SKU.
At line:1 char:1
+ Get-DscConfiguration
+ ~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : InvalidOperation: (MSFT_DSCLocalConfigurationManager:root/Microsoft/...gurationManager) [Get-DscConfig
uration], CimException
+ FullyQualifiedErrorId : ProviderOperationExecutionFailure,Get-DscConfiguration

April 2, 2017 at 8:36 am

There`s another one,here i am trying to setup a http pull server but getting the following error.
At C:\Scripts\DSC1\Mod3\1.Config_HTTPPullServer.ps1:4 char:5
+ Import-DSCResource -ModuleName xPSDesiredStateConfiguration
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Multiple versions of the module 'xPSDesiredStateConfiguration' were found. You can run 'Get-Module -ListAvailable
-FullyQualifiedName xPSDesiredStateConfiguration' to see available versions on the system, and then use the fully qualified name
'@{ModuleName="xPSDesiredStateConfiguration"; RequiredVersion="Version"}'.
At C:\Scripts\DSC1\Mod3\1.Config_HTTPPullServer.ps1:19 char:9
+ xDSCWebService PSDSCPullServer
+ ~~~~~~~~~~~~~~
Undefined DSC resource 'xDSCWebService'. Use Import-DSCResource to import the resource.
At C:\Scripts\DSC1\Mod3\1.Config_HTTPPullServer.ps1:33 char:9
+ xDscWebService PSDSCComplianceServer
+ ~~~~~~~~~~~~~~
Undefined DSC resource 'xDscWebService'. Use Import-DSCResource to import the resource.
+ CategoryInfo : ParserError: (:) [], ParentContainsErrorRecordException
+ FullyQualifiedErrorId : MultipleModuleEntriesFoundDuringParse

April 2, 2017 at 11:45 am

The error messages are telling you what's wrong.

You're attempting to use a Role resource on a client. That's not supported.

You have multiple versions of one resource installed. Also not supported.