Access is denied - PSRemoting

Tagged: 

This topic contains 3 replies, has 3 voices, and was last updated by Profile photo of Wei-Yen Tan Wei-Yen Tan 1 month, 4 weeks ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #48813
    Profile photo of Wei-Yen Tan
    Wei-Yen Tan
    Participant

    Hi,

    I have created a Windows 2012 R2 VM to experiment with some DSC Configuration. I have created two local users and have added them into the Administrators local group.

    I have attempted to PSRemote into the server using the two newly created users.

    I have tried to create a session like this:

    $cred1  = Get-Credential 
    
    $nsn1 = nsn -ComputerName 192.168.1.16 -Credential $cred1
    

    But I get a access is denied. I have confirmed that I can log in locally using the same credentials. It works, so I am a bit baffled as to why its not working as in the help with about_remote_troubleshooting it's saying that the users need to be in the local administrators group which I have added in these users too..

    I have added the server to the trustedhosts as well..
    I am sorry if this seems a bit basic but I don't understand what I am missing. Any help or guidance what I should be looking for would be most appreciated.

    • This topic was modified 1 month, 4 weeks ago by Profile photo of Wei-Yen Tan Wei-Yen Tan.
    #48816
    Profile photo of kvprasoon
    kvprasoon
    Participant

    Hi Tan,

    Is PowerShell remoting enabled on remote host ?

    It would be better to read the help for about_remote_troubleshooting, everything you need is mentioned there.

    regards,
    kvprasoon

    #48847
    Profile photo of Will Anderson
    Will Anderson
    Keymaster

    Hi there Wei-Yen. Is the machine on the domain? If so, can you post the error message you're receiving?

    #48853
    Profile photo of Wei-Yen Tan
    Wei-Yen Tan
    Participant

    Remoting does work on the administrator. I thought that I would try and run winrm quickconfig on the destination server. and realized that local users are not added to the list of usrs that can remote in....EVEN if they are in the list of local administrators. Once i ran quickconfig it all worked. Learn something new every day. 🙂

    Thanks for everyone's help.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.