add secundair smtp adress to mailpublicfolder exchange online

This topic contains 2 replies, has 3 voices, and was last updated by Profile photo of Albert van Boerum Albert van Boerum 2 weeks, 5 days ago.

  • Author
    Posts
  • #70053
    Profile photo of Jeremy-Smit
    Jeremy-Smit
    Participant

    Dear people,

    I try to add a secundair smtp address to a public folder emailbox.

    But it is not working.

    i tried the following thing

    $PF = Get-MailPublicFolder “Offerte”
    $PF.EmailAddresses += “dgn-offerte@010notaris.nl”
    $PF | Set-MailPublicFolder 
    

    but i get the follwoing message
    WARNING: the command completed succesfully but no setting of Offerte have been modified

  • #70092
    Profile photo of Don Jones
    Don Jones
    Keymaster

    It would probably be easier to use Set-MailPublicFolder to set the entire collection of email addresses that you want. E.g., create an array with the existing one(s) as well as your new one, and then pass that to -EmailAddresses. But you also need to provide an email type identifier, as described at https://technet.microsoft.com/en-us/library/bb123707(v=exchg.160).aspx.

  • #70101
    Profile photo of Albert van Boerum
    Albert van Boerum
    Participant

    Hi Jeremy-Smit,

    first, you should properly remove any real e-mail addresses from the code when posting. The reason is obvious I think 🙂

    I would suggest to change the code to:

    $PF = Get-MailPublicFolder "Offerte"
    $PFEmailAddresses = "SMTP:dgn-offerte@010notaris.nl"
    Set-MailPublicFolder -Identity $PF -EmailAddresses $PFEmailAddresses
    

You must be logged in to reply to this topic.