Author Posts

March 13, 2016 at 12:40 pm

I am extremely new to powershell. So for one of my networking classes we are trying to ass a core server to a domain that we have created. Mind you this is via a VM network. While trying to figure out how to configure my network adapters, for some reason there is two, I think i removed the second adapter names ethernet 2. The fist adapter is not working to connect computer to the domain and from what my instructor is say I need to try and use the second one. The second one shows up with the get-netadapter command but does not show anything with the ipconfig command. I'm not sure how to bring the second one back so that I can configure it. So i guess my question is does anyone know how to go about bringing back that second adapter. The class does not give us any access to the VM configurations so everything has to be done through powershell or the CLI. The core computer is using windows server 2012 r2.

March 13, 2016 at 2:51 pm

Use 'sconfig' for the initial setup of a server core install. Type 'sconfig' in PowerShell or command prompt to access the menu.

March 13, 2016 at 4:48 pm

If you've actually removed the NIC, then it might require the host machine administrator to re-add it.

March 14, 2016 at 3:01 am

Hope this will help you out.

First to get all network adapters including the hidden like below.
Get-NetAdapter -Name * -IncludeHidden

Then filter out with the one which you want to enable it.
Get-NetAdapter -Name * -IncludeHidden | where name -like "local area connection* 5"

You can pipe above result to enable-netadapter to enable the adapter, which restarts the network adapter as well.
Get-NetAdapter -Name * -IncludeHidden | where name -like "local area connection* 5" | Enable-NetAdapter

If you want to set adapter properties then set-netadapter can be used

March 20, 2016 at 12:21 am

Thanks for getting back so promptly, I wish I knew about sconfig before this issue came up.
I tried enabling the netadapter after filtering and it still will not let me config. I think you are right Don, I need to try an have someone on their end enable it.