Author Posts

August 10, 2018 at 4:52 am

Recently updated to windows 10 1803 version and the PowerShell autocomplete not working while click ctl+space getting an error.Is any solution for this?

August 10, 2018 at 5:11 am

This has been reported in certain OS version, specifically the one you are now using.
This is an OS specific root cause. Not only does the intellisense (meaning the popup lists), but when you hit CRTL+J the snippets don't appear either.
Now, that still works. When typing the command, use the tab key to cycle through the options. When using snippets, CRTL+J and type a unique snippet name and hit enter.
Now, all that being said, recent updates fixes this issue.
My main system, which is not having this issue.

Get-WmiObject -Class $Win32_OperatingSystem | Format-Table -AutoSize

SystemDirectory     Organization BuildNumber RegisteredUser SerialNumber            Version   
---------------     ------------ ----------- -------------- ------------            -------   
C:\WINDOWS\system32              17134                      00330-50027-66869-AAOEM 10.0.17134


$PSVersionTable| Format-Table -AutoSize

Name                      Value                                   
----                      -----                                   
PSVersion                 5.1.17134.165                           
PSEdition                 Desktop                                 
PSCompatibleVersions      {1.0, 2.0, 3.0, 4.0, 5.0, 5.1.17134.165}
BuildVersion              10.0.17134.165                          
CLRVersion                4.0.30319.42000                         
WSManStackVersion         3.0                                     
PSRemotingProtocolVersion 2.3                                     
SerializationVersion      1.1.0.1  

My WIN10 skip ahead insider build, not having the issue

    PS C:\> Get-WmiObject -Class Win32_OperatingSystem | Format-Table -AutoSize

    SystemDirectory     Organization BuildNumber RegisteredUser SerialNumber            Version   
    ---------------     ------------ ----------- -------------- ------------            -------   
    C:\WINDOWS\system32              18204       Windows User   00329-10280-00000-AA471 10.0.18204

    PS C:\> $PSVersionTable| Format-Table -AutoSize

    Name                      Value                  
    ----                      -----                  
    PSVersion                 5.1.18204.1001         
    PSEdition                 Desktop                
    PSCompatibleVersions      {1.0, 2.0, 3.0, 4.0...}
    BuildVersion              10.0.18204.1001        
    CLRVersion                4.0.30319.42000        
    WSManStackVersion         3.0                    
    PSRemotingProtocolVersion 2.3                    
    SerializationVersion      1.1.0.1
My Win10 fast ring insider not have the issue

    Get-WmiObject -Class Win32_OperatingSystem | Format-Table -AutoSize

    SystemDirectory     Organization BuildNumber RegisteredUser SerialNumber            Version   
    ---------------     ------------ ----------- -------------- ------------            -------   
    C:\WINDOWS\system32              17733                      00330-80000-00000-AA275 10.0.17733



     $PSVersionTable| Format-Table -AutoSize

    Name                      Value                  
    ----                      -----                  
    PSVersion                 5.1.17733.1000         
    PSEdition                 Desktop                
    PSCompatibleVersions      {1.0, 2.0, 3.0, 4.0...}
    BuildVersion              10.0.17733.1000        
    CLRVersion                4.0.30319.42000        
    WSManStackVersion         3.0                    
    PSRemotingProtocolVersion 2.3                    
    SerializationVersion      1.1.0.1                

If you can't update to the latest version to address this, then you will need to use the steps above or switch to VSCode as your editor.

Now, VSCode does have it's hiccups with intellisense, but the workaround is just backspace and start the line over, use CRTL+Space or reload/restart VSCode.

'social.technet.microsoft.com/Forums/en-US/5718f612-4067-4529-8181-d16f31bbb289/powershell-ise-intellisense-in-windows-10-1803-does-not-work'

'windowsserver.uservoice.com/forums/301869-powershell/suggestions/34201435-powershell-intellisense-broken-on-windows-10-1803'

'answers.microsoft.com/en-us/windows/forum/windows_10-performance/intellisense-is-not-properly-working-in-powershell/12ffc93f-9235-4d61-9138-bf52343363d7'