Can a WMF 5 pull server manage a WMF 4 node

This topic contains 3 replies, has 4 voices, and was last updated by Profile photo of Flynn Bundy Flynn Bundy 7 months, 2 weeks ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #35178
    Profile photo of Ed O'Connor
    Ed O’Connor
    Participant

    Hi,

    I have been testing DSC and just upgraded the Pull server from WMF 4 to 5 preview. I have two nodes (1 WMF4 and 1 WMF5 preview). When the pull server was WMF4 everything worked fine on both servers. After upgrading the pull server to WMF5 preview and after pushing the LCM configurations to the nodes; the node with WMF4 does not seem to be getting the configuration. When i run a test-dscconfiguration or get-dscconfiguration I get a "Test-DSCConfiguration : current configuration does not exist"

    This is crazy! Please help/advise!

    #35179
    Profile photo of Don Jones
    Don Jones
    Keymaster

    There are some differences that can cause problems. Have you checked the log on both server and node?

    #35186
    Profile photo of Yuan Li
    Yuan Li
    Participant

    I encountered similar issue when I test WMF 5 preview. I think some syntax are not compatible and I have to install WMF 5 on both nodes and server to get it work!

    #35203
    Profile photo of Flynn Bundy
    Flynn Bundy
    Participant

    I ran into this recently also.

    Mike Robbins has a great post discussing the issue and a quick script to regex change some of the formatting in a .mof that was generated on a PS Version 4 host to work with Version 5 LCM.

    http://mikefrobbins.com/2014/10/30/powershell-desired-state-configuration-error-undefined-property-configurationname/

    The issue itself has been mentioned to MS, so they're aware of the issue.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.