Cannot download xWebAdministration module from Pull Server

This topic contains 1 reply, has 1 voice, and was last updated by Profile photo of Matt Williams Matt Williams 1 year, 9 months ago.

  • Author
    Posts
  • #28803
    Profile photo of Matt Williams
    Matt Williams
    Participant

    I've seen a couple of posts about this already but they don't cover this particular issue,

    I've set up a Pull Server and I'm trying to get a target server (Server Core 2012) to install IIS, configure a website and create some shares.

    I am using the xsmbShare and xWebAdministration modules for this. Both modules are zipped (with the correct naming convention) and stored in the C:\Program Files\WindowsPowershell\DSCService\Modules folder on the Pull Server

    Both zipfiles have a corresponding checksum file.

    However, the target server simply will NOT download the xWebAdministration module (and therefore, none of the config happens).

    If I remove the sections from the MOF file that use the xWebAdministration module then everything works OK. The xSMBShare module is downloaded, IIS is installed and the shares are created.

    It's obviously just a problem with the xWebAdministration module but I can't see what would be stopping it from being downloaded.

    This is all being done with PS4. No plans to use PS5 until final release

  • #28806
    Profile photo of Matt Williams
    Matt Williams
    Participant

    Never mind, found the answer. It's a bug

    http://stackoverflow.com/questions/22084414/deploying-custom-resource-through-dsc-pullserver-fails-to-extract-the-module

    Recreating the zip with SendTo > Compressed folder solves the issue

You must be logged in to reply to this topic.