Certain commands won't run

This topic contains 3 replies, has 2 voices, and was last updated by  Rob 3 months, 3 weeks ago.

  • Author
  • #84485


    Get-WindowsFeature and Install-WindowsFeature won't run on a server 2012 core. Keep getting an error "Configuration failed to initialize".

  • #84490


    Update-Help throws the same error also:
    S C:\> update-help -Force
    pdate-help : Failed to update Help for the module(s) 'Microsoft.PowerShell.Management, Microsoft.PowerShell.Security
    icrosoft.PowerShell.Utility, Microsoft.WSMan.Management, ServerManager, AppLocker, BestPractices, CimCmdlets, Dism,
    nternational, IscsiTarget, Kds, Microsoft.PowerShell.Diagnostics, Microsoft.PowerShell.Host, PKI,
    SDesiredStateConfiguration, PSScheduledJob, PSWorkflow, PSWorkflowUtility, RemoteDesktop, ServerCore, TLS,
    indowsErrorReporting, Microsoft.PowerShell.Core' with UI culture(s) {en-US} : Configuration system failed to
    t line:1 char:1
    update-help -Force
    + CategoryInfo : InvalidOperation: (:) [Update-Help], Exception
    + FullyQualifiedErrorId : UnknownErrorId,Microsoft.PowerShell.Commands.UpdateHelpCommand


  • #84521


    Sure it will. PoSH is what MS wants you to use for SC.
    Those error means either it is not installed / enabled...

    at the cmd.exe prompt — Use the Deployment Image Servicing and Management (DISM.exe) tool to enable PowerShell:

    dism.exe /online /enable-feature /featurename:MicrosoftWindowsPowerShellRoot


    dism.exe /online /enable-feature /featurename:MicrosoftWindowsPowerShell /all

    ...or you are sitting at the cmd.exe prompt typing PoSH cmdlets. Of course cmd.exe has not idea what PoSH cmdlets are. SC defaults to cmd.exe, not PoSH. You have to type PowerShell in cmd.exe prompt to bring up PoSH before trying to use its tools.

    You can change the default from cmd.exe to powershell.exe, if you wish. See the information below:


  • #85126


    Unfortunately, neither dism command worked. I'm going to recommend a rebuild.

You must be logged in to reply to this topic.