Certain commands won't run

This topic contains 3 replies, has 2 voices, and was last updated by  Rob 2 weeks, 4 days ago.

  • Author
    Posts
  • #84485

    Rob
    Participant

    Get-WindowsFeature and Install-WindowsFeature won't run on a server 2012 core. Keep getting an error "Configuration failed to initialize".

  • #84490

    Rob
    Participant

    Update-Help throws the same error also:
    S C:\> update-help -Force
    pdate-help : Failed to update Help for the module(s) 'Microsoft.PowerShell.Management, Microsoft.PowerShell.Security
    icrosoft.PowerShell.Utility, Microsoft.WSMan.Management, ServerManager, AppLocker, BestPractices, CimCmdlets, Dism,
    nternational, IscsiTarget, Kds, Microsoft.PowerShell.Diagnostics, Microsoft.PowerShell.Host, PKI,
    SDesiredStateConfiguration, PSScheduledJob, PSWorkflow, PSWorkflowUtility, RemoteDesktop, ServerCore, TLS,
    indowsErrorReporting, Microsoft.PowerShell.Core' with UI culture(s) {en-US} : Configuration system failed to
    nitialize
    t line:1 char:1
    update-help -Force
    ~~~~~~~~~~~~~~~~~~
    + CategoryInfo : InvalidOperation: (:) [Update-Help], Exception
    + FullyQualifiedErrorId : UnknownErrorId,Microsoft.PowerShell.Commands.UpdateHelpCommand

    S

  • #84521

    postanote
    Participant

    Sure it will. PoSH is what MS wants you to use for SC.
    Those error means either it is not installed / enabled...

    at the cmd.exe prompt — Use the Deployment Image Servicing and Management (DISM.exe) tool to enable PowerShell:

    dism.exe /online /enable-feature /featurename:MicrosoftWindowsPowerShellRoot

    ...or

    dism.exe /online /enable-feature /featurename:MicrosoftWindowsPowerShell /all

    ...or you are sitting at the cmd.exe prompt typing PoSH cmdlets. Of course cmd.exe has not idea what PoSH cmdlets are. SC defaults to cmd.exe, not PoSH. You have to type PowerShell in cmd.exe prompt to bring up PoSH before trying to use its tools.
    'youtube.com/watch?v=djUWPvQAQZU'
    'youtube.com/watch?v=zOBSDVPYVH0'

    You can change the default from cmd.exe to powershell.exe, if you wish. See the information below:

    'blogs.technet.microsoft.com/uktechnet/2016/02/10/powershell-and-server-core'
    'brandonlawson.com/powershell/default-to-powershell-in-windows-2012-core'
    'technet.microsoft.com/en-us/library/jj574205(v=ws.11).aspx'
    'docs.microsoft.com/en-us/powershell/module/microsoft.powershell.core/enable-psremoting?view=powershell-5.1'

  • #85126

    Rob
    Participant

    Unfortunately, neither dism command worked. I'm going to recommend a rebuild.

You must be logged in to reply to this topic.