connecting exchange server EMS from powershell remoting via HTTPS


This topic contains 2 replies, has 2 voices, and was last updated by Profile photo of Rahul Nair Rahul Nair 4 weeks, 1 day ago.

  • Author
  • #54602
    Profile photo of Rahul Nair
    Rahul Nair


    I'm trying to resolve an issue we are facing.

    we are able to communicate to Exchange Server EMS Script from remote machine through winRM HTTP authentication.

    $newSession = New-PSSession -ConfigurationName Microsoft.Exchange -ConnectionUri -Authentication Kerberos -Credential $Credentials
    Import-PSSession $newSession

    But we have to impose WinRM HTTPS, so I have set everything required for that including certificate creation , winRM settings etc.

    And we are able to connect to remote machine where exchange server is available:

    Enter-PSSession -ComputerName -Credential $credentials -UseSSL

    and this works.

    Now when I'm using -UseSSL in New-PSSession/Enter-PSSession for EMS, its not working:

    $newSession = New-PSSession -ConfigurationName Microsoft.Exchange -ConnectionUri -Credential $Credentials -UseSSL

    Error: New-PSSession : Parameter set cannot be resolved using the specified named parameters.

    Please note: I need WinRM (powershell) Connectivity through HTTPS: -UseSSL Authentication. Not with Kerberos/Defaut/CredSSP

  • #54629
    Profile photo of Rob Simmers
    Rob Simmers

    Have looked at Secrets of Powershell remoting to see if answers you question?

  • #54635
    Profile photo of Rahul Nair
    Rahul Nair

    Here is the conclusion:
    -UseSSL tells the command to use the HTTPS port.
    SSL is not an authentication it is a protocol. Kerberos/CredSSP/basic are all authentication protocols. SSL is the transport protocol. Authentication is separate from transport.
    Note again that all PowerShell remoting via WSMan is always encrypted even if it is HTTP. Kerberos is always encrypted.

    What I should do is, specify the https prefix instead of using the -useSSL switch which will ensure that connection is over https (";. The -useSSL is meant to be used when you using the -ComputerName parameter.

    • This reply was modified 4 weeks, 1 day ago by Profile photo of Rahul Nair Rahul Nair.

You must be logged in to reply to this topic.