DefaultAppPool crashes after PullServer Installation

This topic contains 1 reply, has 2 voices, and was last updated by Profile photo of Don Jones Don Jones 4 months, 4 weeks ago.

  • Author
    Posts
  • #46700
    Profile photo of Stan Hristov
    Stan Hristov
    Participant

    Hi all,

    I'm going to share one problem that I noticed and I was not able to find a solution to. Perhaps this will save someone a little troubleshooting time.

    Here is the story.
    I have a testing server that I wanted to use as a pull server, so I used the latest xPSDesiredStateConfiguration (at this time it's 3.12.0.0) and everything worked perfectly.
    Unfortunately I was using the Default Web Site for hosting a simple html report (generated with PS of course 🙂 ) and it stopped working. The DefaultAppPool started to crash with the below errors in the server application and system logs:

    PS C:\Windows\system32> Get-EventLog -LogName Application -Index 97835 | Select-Object -Property EntryType,Source,Message | fl *
    
    
    EntryType : Error
    Source    : W3SVC-WP
    Message   : The Module DLL 'C:\Windows\SysWOW64\inetsrv\IISSelfSignedCertModule.dll' could not be loaded due to a configuration problem. The current configuration only supports loading images built
                for a AMD64 processor architecture. The data field contains the error number. To learn more about this issue, including how to troubleshooting this kind of processor architecture
                mismatch error, see http://go.microsoft.com/fwlink/?LinkId=29349.
    PS C:\Windows\system32> Get-EventLog -LogName System -Index 129681 | Select-Object -Property EntryType,Source,Message | fl *
    
    
    EntryType : Error
    Source    : WAS
    Message   : Application pool 'DefaultAppPool' is being automatically disabled due to a series of failures in the process(es) serving that application pool.

    Then I removed the PullServer using the configuration in the examples of xPSDesiredStateConfiguration (Sample_xDscWebServiceRemoval.ps1 to be exact) but the problem remained.
    One workaround was to set the DefaultAppPool enable32BitAppOnWin64 setting to True.

    PS C:\Windows\system32> (Get-ItemProperty -Path IIS:\AppPools\DefaultAppPool -Name enable32BitAppOnWin64).Value
    True

    That works but I wanted to revert to the original state so here is what I did:

    1. Remove Native Module "IISSelfSignedCertModule(32bit)" from the IIS (server level)
    2. Remove file "IISSelfSignedCertModule.dll" from C:\Windows\SysWOW64\inetsrv and C:\Windows\System32\inetsrv

    That's it.

  • #46736
    Profile photo of Don Jones
    Don Jones
    Keymaster

    Thanks for sharing!

You must be logged in to reply to this topic.