Double hop problem?

This topic contains 1 reply, has 1 voice, and was last updated by Profile photo of Rene Falkenberg Rene Falkenberg 2 years, 4 months ago.

  • Author
    Posts
  • #17651
    Profile photo of Rene Falkenberg
    Rene Falkenberg
    Participant

    Hello,

    I'm having some issues with what i think is a double-hop problem between servers in two different domains.

    On scorch1.test.local I do a "Enter-PSSession app1.corp.local -Credential corp\testuser" in this session i try to do a "Test-Path \\app2.corp.local\d$\Data\Pre-release"

    But i'm getting the following error:

    Test-Path : Access is denied
    + CategoryInfo : PermissionDenied: (\\app2.corp.l...ata\Pre-release:String) [Test-Path], UnauthorizedAc
    cessException
    + FullyQualifiedErrorId : ItemExistsUnauthorizedAccessError,Microsoft.PowerShell.Commands.TestPathCommand

    The account corp\testuser is for testing purpose and is in the Administrator Groups of all servers. If i logon directly on app1.corp.local and try to do the same Test-Path it works.

    On scorch1.test.local I tried to "Enable-WSManCred -Role Client -Delegation app1.corp.local" and on app1.corp.local "Enable-WSManCred -Role Server" but I get the same error.

  • #17652
    Profile photo of Rene Falkenberg
    Rene Falkenberg
    Participant

    Problem found... I have forgotten two things

    1. Setting up WSMAN as on page 41 of Secrets of PowerShell Remoting book found on this site also 🙂
    2.. Enter-PSSession app1.corp.local -Credential corp\testuser should be "Enter-PSSession app1.corp.local -Credential corp\testuser -Authentication CredSSP"

You must be logged in to reply to this topic.