Author Posts

March 2, 2015 at 12:38 pm

Hi,

I am working my way through the 12 "built in" DSC Resources listed here:

https://technet.microsoft.com/en-us/library/dn249921.aspx

Of the 10 so far that I have test, 8 work and 2 fail.

The Group Resource is failing. The Log Resource, doesn't fail, but I cannot find the log entries anywhere.

Group Resource error is:

[blockquote]This event indicates that failure happens when LCM is processing the configuration. ErrorId is 0x1. ErrorDetail is The SendConfigurationApply function did not succeed.. ResourceId is [Group]GroupExample and SourceInfo is C:\DSC\TestDSCWebsiteConfig.ps1::153::9::Group. ErrorMessage is The PowerShell provider MSFT_GroupResource threw one or more non-terminating errors while running the Test-TargetResource functionality. These errors are logged to the ETW channel called Microsoft-Windows-DSC/Operational. Refer to this channel for more details..[/blockquote]

Log Resource issue is that in neither the Analytic or Debug logs do I see log entries. I have prepended all my log text with ZZZZZ so that it is obvious that it's from me. Analytic page is full of entries but nothing from me.

Any ideas?

Thanks,
Dave

March 3, 2015 at 9:53 am

Log Resource writes to an operational log, not one of the standard Application/Security/Server logs. Browse through the log list in event viewer and you should be able to find it – "Microsoft-Windows-DSC/Operational." That's neither Analytic nor Debug. You can run Get-WinEvent, I believe, to retrieve them also, which may be easier.

The error for your Group resource will be in that location.