DSC - Cannot find module - Node Pull mode

This topic contains 1 reply, has 2 voices, and was last updated by Profile photo of Nitin Gupta Nitin Gupta 1 week, 4 days ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #54195
    Profile photo of Bjørn Roalkvam
    Bjørn Roalkvam
    Participant

    Using Server 2012R2 with WMF 5.

    I sometimes experience the following fault on nodes pulling dscresources from a Pull Server:

    Cannot find module SharePointDSC_1.2.0.0 from the server https://vm02:8080/PSDSCPullServer.svc/Modules(ModuleName='SharePointDSC',ModuleVersion='1.2.0.0')/ModuleContent.
        + CategoryInfo          : ResourceUnavailable: (root/Microsoft/...gurationManager:String) [], CimException
        + FullyQualifiedErrorId : WebDownloadManagerModuleNotFound,Microsoft.PowerShell.DesiredStateConfiguration.Commands.GetDscModuleCommand
        + PSComputerName        : localhost 

    The fix is mostly to recreate the Mof file, then on the node run update-dscConfiguration -wait -verbose. It then finds all modules and runs fine.

    Anyone else experiencing this kind of errors? Can anything be done to avoid this kind of "bug-faults"

    Brgs

    Bjørn

    #54211
    Profile photo of Nitin Gupta
    Nitin Gupta
    Participant

    One possible reason is if you have deployed the updated module (with new version) to the node but haven't updated the compiled configuration to reflect new module version in the MOF. Next time you hit this issue, open the MOF file and verify that the ModuleVersion reported in the MOF is same as what is available on the Node.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.