DSC Exception when installing package

This topic contains 12 replies, has 4 voices, and was last updated by  JVimes 2 years ago.

  • Author
    Posts
  • #26914

    Kris Parr
    Participant

    I'm trying to install BizTalk 2013 Std from a local MSI, but get the following exception in the DSC event log. Any idea what's going wrong ?

    Message Object reference not set to an instance of an object.
    HResult -2147467261
    StackTrack at Microsoft.PowerShell.DesiredStateConfiguration.Internal.DownloadManagerBase.GetDownloadManagerNameFromCimInstanceV2(CimInstance cimInstancev2)
    at Microsoft.PowerShell.DesiredStateConfiguration.Internal.DownloadManagerBase.GetPluginModuleName(IntPtr metaConfigHandle, PlugInType plugInType, String& pluginName, ErrorRecord& errorRecord, String partialConfigName)
    at Microsoft.PowerShell.DesiredStateConfiguration.Internal.DownloadManagerBase.ImportDownloadManager(IntPtr metaConfigHandle, Boolean debugMode, PlugInType plugin, ErrorRecord& errorRecord, String partialConfigName)
    at Microsoft.PowerShell.DesiredStateConfiguration.Internal.DownloadManagerBase.InstallDscDocumentDependencies(IntPtr metaConfigHandle, IntPtr& errorInstanceHandle, String mofFileName, UInt32& getActionStatusCode)
    at Microsoft.PowerShell.DesiredStateConfiguration.Internal.DscPluginManagedEntryWrapper.Push_DependencyCheck_ManagedPlugin(IntPtr provContext, IntPtr metaConfig, String mofFileName, IntPtr getActionStatusCode, IntPtr extendedError, String jobIdNative)

  • #26915

    Dave Wyatt
    Moderator

    That message shouldn't have anything to do with the Package resource... can you apply _any_ configuration to that machine? Have you recently updated to a new version of the WMF 5 preview, by chance?

  • #26916

    Kris Parr
    Participant

    It's a fresh VM which I install WMF 5 april 2015 on to. I can apply other configuration to the box, it's just this msi that's failing.
    I also get the following error in the verbose output of my desktop machine I'm using to push the config, it seems this may be something permission related though the user the resource is running as is a local admin.

    The WS-Management service cannot process the request. The WMI service or the
    WMI provider returned an unknown error: HRESULT 0x80041033
    + CategoryInfo : ResourceUnavailable: (root/Microsoft/...guration
    Manager:String) [], CimException
    + FullyQualifiedErrorId : HRESULT 0x80041033

  • #26917

    Dave Wyatt
    Moderator

    What output do you get when you run Get-DscLocalConfigurationManager ?

  • #26918

    Kris Parr
    Participant

    ActionAfterReboot : ContinueConfiguration
    AgentId : 57E89A23-1A7E-11E5-80BA-000D3AB0FE85
    AllowModuleOverWrite : False
    CertificateID : xxxxxx
    ConfigurationDownloadManagers : {}
    ConfigurationID :
    ConfigurationMode : ApplyOnly
    ConfigurationModeFrequencyMins : 15
    Credential :
    DebugMode : {All}
    DownloadManagerCustomData :
    DownloadManagerName :
    LCMCompatibleVersions : {1.0, 2.0}
    LCMState : PendingConfiguration
    LCMStateDetail :
    LCMVersion : 2.0
    MaxPendingConfigRetryCount :
    StatusRetentionTimeInDays : 10
    PartialConfigurations :
    RebootNodeIfNeeded : True
    RefreshFrequencyMins : 30
    RefreshMode : Push
    ReportManagers : {}
    ResourceModuleManagers : {}
    PSComputerName :

  • #26919

    Dave Wyatt
    Moderator

    Try changing DebugMode from 'All' to 'ForceModuleImport', and re-apply your configuration by running Start-DscConfiguration -Force. 'All' includes some new debugging features, which may be causing you some trouble.

  • #26923

    Kris Parr
    Participant

    Doesn't seem to make a difference...

    Stripping the config back to just the package install and I still get the error, though I get the following in the DSC event logs.

    Message Processing data for a remote command failed with the following error message: The WSMan provider host process did not return a proper response. A provider in the host process may have behaved improperly. For more information, see the about_Remote_Troubleshooting Help topic.
    HResult -2146233087
    StackTrack at System.Management.Automation.Runspaces.AsyncResult.EndInvoke()
    at System.Management.Automation.PowerShell.CoreInvokeRemoteHelper[TInput,TOutput](PSDataCollection`1 input, PSDataCollection`1 output, PSInvocationSettings settings)
    at System.Management.Automation.PowerShell.CoreInvoke[TInput,TOutput](PSDataCollection`1 input, PSDataCollection`1 output, PSInvocationSettings settings)
    at System.Management.Automation.PowerShell.CoreInvoke[TOutput](IEnumerable input, PSDataCollection`1 output, PSInvocationSettings settings)
    at System.Management.Automation.PowerShell.Invoke(IEnumerable input, PSInvocationSettings settings)
    at Microsoft.PowerShell.DesiredStateConfiguration.Internal.ResourceProviderAdapter.ExecuteProviderCommand(IntPtr resourceConfigurationInstanceHandle, IntPtr regInstanceHandle, String operationCmd, LCMDebugMode debugMode, UInt32& resultStatusHandle, Collection`1& result, ErrorRecord& errorRecord)

  • #26924

    Dave Wyatt
    Moderator

    Hmm, I'm not sure what's going on here. I'll pass a link to this thread on to the MVP mailing list, and see if anyone can help.

  • #26925

    Kris Parr
    Participant

    Great, thanks for your help.

  • #26928

    Ray Hayes
    Participant

    I see you're in PUSH mode but try defining

    DownloadManagerCustomData :
    DownloadManagerName :

    Ray

  • #26946

    Kris Parr
    Participant

    Still failing...

    I guess it's something to do with the BizTalk setup.exe doing something weird.

  • #29926

    JVimes
    Participant

    I'm getting the same trying to run "Install-Package -Force python2" from inside a Script resource. Other calls to Install-Package work (Notepad++, 7zip, winmerge, etc.).

    The WS-Management service cannot process the request. The WMI service or the WMI provider returned an unknown error:
    HRESULT 0x80041033
        + CategoryInfo          : ResourceUnavailable: (root/Microsoft/...gurationManager:String) [], CimException
        + FullyQualifiedErrorId : HRESULT 0x80041033
        + PSComputerName        : localhost
    
  • #29932

    JVimes
    Participant

    It also happens when installing PoshGit the same way, right after it launches Git-2.5.2-64-bit.exe.

You must be logged in to reply to this topic.