DSC issue with Windows Features when reboot is needed


This topic contains 3 replies, has 3 voices, and was last updated by Profile photo of Khon Maxim Khon Maxim 1 year, 5 months ago.

  • Author
  • #25230
    Profile photo of Khon Maxim
    Khon Maxim

    Hi guys,
    recently I've ran into issues when DSC is installing Windows Features that require reboot. So in this case DSC starts applying MOF, then it show message "DSC requires reboot..." But when machine reboots, MOF does not continue to apply. It takes time for DSC to recognize this fact and resume MOF application. It might take up to 1 hour (30min is DSC configured period for node MOF update check). I have to invoke pull manually to speed up the process. I use WMF 4.0. Node is 2008R2 Ent. One of features that requires reboot is "RSAT features"

    Can anyone either confrim or clarify this moment? Maybe there is a workaround for this.

    Many thanks in advance!

  • #25231
    Profile photo of Don Jones
    Don Jones

    A lot of people see this. You're looking less at a DSC problem and more at the way the WindowsFeature module just works at the moment, I think. Keep in mind that DSC is a little like SCCM in that you're meant to be patient with it, not hurry it along. I think this'll likely get better going forward, but right now feature/software installation is definitely a point where the underlying OS sort of demands more patience. I'm not saying it's *acceptable*, mind you, just that it sort of is what it is right now.

    Although frankly, this could also just be Windows' way of punishing you for installing GUI tools on a server. That sort of presumes you're also RDP-ing into the server to manage it. There's a reason the "R" in RSAT stands for "Remote." Slight grin here, but only a little ;).

  • #25245
    Profile photo of David Jones
    David Jones

    The November update to 2012r2 adds the continue on reboot option. prior to that it's reboot and wait for the timer to kick off the next consistency check.

  • #25272
    Profile photo of Khon Maxim
    Khon Maxim

    Hi guys,
    thank you for response! I really appreciate your assistance!

You must be logged in to reply to this topic.