Author Posts

September 4, 2018 at 8:55 am

Hello,

I am not sure if you also assist with DSC questions when it comes to Azure Automation DSC but I will post here, in case someone can kindly advise
Can someone please help me with the following questions,
 
I have set up a Node (Azure VM) to by managed by Azure Automation DSC
 
I setup and applied a simple configuration to stop a service (Adobe update service) and set the start-up mode to manual (default settings are started and automatic).
 
When I first applied the configuration to the Node it worked e.g. stopped the service and set the configuration to manual
 
the LCM (local configuration manager) on the node is set to ApplyAndMontior
 
However when the Node goes out of compliance (which can be seen in the Azure console and via test-DscConfigruation) it does not get pulled back into compliance despite the fact the LCM is set to ApplyAndMonitor
 
If I run the following command
 
Start-DscConfiguration -Wait -Force -ComputerName $ENV:computername -UseExisting
 
The Node immediately comes back into compliance and this is reflected in the Azure console
 
My big problem is I cannot appear to rely on Azure Automation DSC to force the node back into compliance on its own (which is the whole point)
 
How can I troubleshoot this issue? does anyone have any suggestions ?
 
Thanks
 
CXMelga
 

September 4, 2018 at 9:32 am

ApplyAndMontior Just applies and monitor the configuration. What you need here is ApplyAndAutoCorrect

September 4, 2018 at 2:22 pm

Duh!

Thanks very much for taking the time to reply kvprasoon 🙂

CXMelga