Enabled attribute on ADUser not showing on DC\'s

This topic contains 2 replies, has 2 voices, and was last updated by Profile photo of sponsen sponsen 9 months, 4 weeks ago.

  • Author
    Posts
  • #54638
    Profile photo of sponsen
    sponsen
    Participant

    Hi,

    I came over a weird behavior and was wondering if anyone else experience this.

    So, if I run PS (not Run as admin) on a DC, and type

    Get-ADUser username -pr Enabled

    the object returned is NOT showing Enabled – but it dows if i run PS as admin. The same goes for the GUI version of AD, but in the GUI, I'm not able to see Enabled no matter what I try.. Nevertheless, i get the Enabled attribute when i run PS on my client – admin or not. This behavior is equal on all our DC's.

    • This topic was modified 9 months, 4 weeks ago by Profile photo of sponsen sponsen.
  • #54652
    Profile photo of BIJO DEV
    BIJO DEV
    Participant

    The administrator has not given you much privileges in that case you might not be able to find it.

  • #54653
    Profile photo of sponsen
    sponsen
    Participant

    Hi, thanks for your response.
    I am the main administrator.

    As I said, once i elevate the PS console with Run as admin, i get the Enabled attribute. If i use my admin account without pressing Run as admin, i do not see it.

You must be logged in to reply to this topic.