Enter-PSSession : The system cannot find the file specified

This topic contains 5 replies, has 2 voices, and was last updated by Profile photo of Don Jones Don Jones 7 months ago.

  • Author
    Posts
  • #38847
    Profile photo of Rhys Gottwald
    Rhys Gottwald
    Participant

    Hi all,

    I have a server 2012 R, domain controller, with WMF 5. When I try to access it via PSRemote I get the error: Enter-PSSession : The system cannot find the file specified

    I did have access to this server but it stopped about 2 weeks back. Any ideas?

  • #38857
    Profile photo of Don Jones
    Don Jones
    Keymaster

    Can you, from the server console, Enter-PSSession -computername localhost?

  • #38889
    Profile photo of Rhys Gottwald
    Rhys Gottwald
    Participant

    Hi Don,

    Same error when I try it locally.

    Have to let you know, I watch you PS best practices and PS unplugged with Mr. Snover, or rather, Sir Snover, you were rocking the Tony Stark look.

  • #38891
    Profile photo of Don Jones
    Don Jones
    Keymaster

    Make sure your PowerShell console is running as Administrator when you try that local connect.

    If you're getting that error locally, then Remoting is screwed up on the server. You might try running Disable-PSRemoting, and then Enable-PSRemoting, to unscrew it. However, if it remains screwed up, then it's going to be really difficult for me to help you troubleshoot it over the Internet. I'd honestly suggest opening a product support ticket. Remoting has a lot of moving parts under the hood, and if someone's messed with something, it can take a lot of digging to find it.

    And thanks ;).

  • #38924
    Profile photo of Rhys Gottwald
    Rhys Gottwald
    Participant

    Thanx Don, disabling did not work. Would a remove and reinstall work if remoting is gone?

  • #38929
    Profile photo of Don Jones
    Don Jones
    Keymaster

    A remove and reinstall of WMF? I've no idea – it might, it might not. Something at the OS level is messed up.

You must be logged in to reply to this topic.