Export-StartLayout as BIN not working!

This topic contains 12 replies, has 2 voices, and was last updated by Profile photo of Daan Weda Daan Weda 3 days, 17 hours ago.

  • Author
    Posts
  • #58935
    Profile photo of Chris Ediger
    Chris Ediger
    Participant

    I'm trying to export a start layout for an image. I can't get Export-StartLayout path c:\ -As BIN to work. It doesn't like the -As parameter. What am I missing? Same behavior on Windows 10 1511 and 1607.

  • #58939
    Profile photo of Daan Weda
    Daan Weda
    Participant

    When I look at the cmdlet I don't see the param -As maybe this is not needed anymore in PS 5?
    Just run Export-StartLayout -Path C:\test.bin

    • #58941
      Profile photo of Chris Ediger
      Chris Ediger
      Participant

      Tried that. It creates a nice xml formatted file with a .bin extension that Import-StartLayout doesn't like.

    • #58942
      Profile photo of Daan Weda
      Daan Weda
      Participant

      For me its working fine what error message you get back?

    • #58960
      Profile photo of Chris Ediger
      Chris Ediger
      Participant

      How do you type it? This is how I do it:

      Export-StartLayout -path c:\exportdir\starylayout.bin -As BIN

      I get this error:

      Export-StartLayout : A parameter cannot be found that matches parameter name 'as'.

      I've tried it on three different machines now. All with the same result.

    • #59028
      Profile photo of Daan Weda
      Daan Weda
      Participant

      I just run it like this

      Export-StartLayout -path c:\exportdir\starylayout.bin

      It give me back a .bin file in that directory.

    • #59032
      Profile photo of Chris Ediger
      Chris Ediger
      Participant

      Yes, but it's not actually a binary file. It's still an XML. I tried exporting it like that then doing import-starylayout and it didn't like the format.

    • #59038
      Profile photo of Daan Weda
      Daan Weda
      Participant

      what kind of extension the file got then xml?
      I see in the get-help they only talk about exporting xml I guess you already tried to export xml and import xml?

    • #59041
      Profile photo of Chris Ediger
      Chris Ediger
      Participant

      For some reason Import-StaryLayout will only work with binary files.

      From the Import-StartLayout help:
      The Export-StartLayout cmdlet also exports layouts as .xml files, but this cmdlet imports only .bin files.

    • #59044
      Profile photo of Daan Weda
      Daan Weda
      Participant

      Ok maybe you run into a bug which OS and PowerShell version are you running?

    • #59047
      Profile photo of Chris Ediger
      Chris Ediger
      Participant

      3 separate computers. This cmdlet works with Windows 10 only. I've tried it on both 1511 and 1607.

    • #59049
      Profile photo of Daan Weda
      Daan Weda
      Participant

      I have Build 14393

  • #59005
    Profile photo of Chris Ediger
    Chris Ediger
    Participant

    Is anyone else able to run this cmdlet successfully? And if you did is it actually a binary file? If so how do you format it?

You must be logged in to reply to this topic.