Find-Module Warning Uri Invalid

Welcome Forums General PowerShell Q&A Find-Module Warning Uri Invalid

Viewing 1 reply thread
  • Author
    Posts
    • #234442
      Participant
      Topics: 1
      Replies: 0
      Points: 31
      Rank: Member

      I’m new to PowerShell taking an online course to learn the ropes. I got to the section on Modules and everything was fine until I issued the Find-Module command.

      Find-Module returns:

      Warning: Unable to resolve package source 'https://www.powershellgallery.com/api/v2'.

      I’m running PSVersion

      Major    Minor   Build    Revision
      5               1          14409    1018

      I found this aritcle relating to this warning: https://stackoverflow.com/questions/53358723/unable-to-find-repository-on-update-module

      But this fix this does I can’t do because I get another error:

      Register-PSRepository: The specified Uri 'https://www.powershellgallery.com/api/v2' for parameter 'SourceLocation' is an invalid Web Uri. Please ensure it meets the Web Uri requirements.

      I’m stuck at this point I don’t know what to do.

      Not sure what info is pertinent but I’m running these version of PowerShellGet and PackageManagement:

      PowerShellGet = 2.2.3

      PackageManagement = 1.4.6

      Also here is the output of Get-PSRepository:

      Name InstallationPolicy SourceLocation
      ---- ------------------ --------------
      PSGallery Untrusted https://www.powershellgallery.com/api/v2

      Any help would be greatly appreciated. I don’t want to continue on my course until I’ve got a grasp on modules!

    • #235381
      Senior Moderator
      Topics: 9
      Replies: 1236
      Points: 4,443
      Helping Hand
      Rank: Community Hero

      It says unable to resolve. Are you connected to internet ?

Viewing 1 reply thread
  • You must be logged in to reply to this topic.