Get-CimClass -ClassName Accepting Wildcard

Welcome Forums General PowerShell Q&A Get-CimClass -ClassName Accepting Wildcard

Viewing 3 reply threads
  • Author
    Posts
    • #230167
      Participant
      Topics: 1
      Replies: 1
      Points: -6
      Rank: Member

      Hello,

      I see a discrepancy between the help command in powershell and the powershell online help.

      If I run help Get-CimClass -full, I see the parameter of -ClassName with Accept wildcard characters? false.

      But, if I go to the online help site. https://docs.microsoft.com/en-us/powershell/module/cimcmdlets/get-cimclass?view=powershell-7 I see the parameter of -ClassName with Accept wildcard characters? true.

      I have run an update-help on my powershell, but still do not see a change on my powershell.  When I run a test command, the parameter does accept wildcard characters.  What am I missing?

      • This topic was modified 6 months, 2 weeks ago by bseaba16.
    • #230176
      Participant
      Topics: 7
      Replies: 2458
      Points: 6,439
      Helping Hand
      Rank: Community MVP

      Seems like you’ve found a bug. You should file it there: https://github.com/PowerShell/PowerShell/issues

    • #230179
      Participant
      Topics: 1
      Replies: 1
      Points: -6
      Rank: Member

      Issue filed.  Thank you.

    • #230335
      js
      Participant
      Topics: 32
      Replies: 850
      Points: 2,752
      Helping Hand
      Rank: Community Hero

      The docs show powershell 7 by default.

      • This reply was modified 6 months, 2 weeks ago by js.
Viewing 3 reply threads
  • The topic ‘Get-CimClass -ClassName Accepting Wildcard’ is closed to new replies.