Get-MobileDevice cmdlet showing odd UserDisplayName

Welcome Forums General PowerShell Q&A Get-MobileDevice cmdlet showing odd UserDisplayName

This topic contains 4 replies, has 3 voices, and was last updated by

Jon
 
Participant
5 months ago.

  • Author
    Posts
  • #104294

    Participant
    Points: 0
    Rank: Member

    I have a script that connects to the ActiveSync service and queries for any device currently sitting in quarantine. It then ports that information into a CSV file, capturing the identity, devicetype, userdisplayname, and deviceid fields for each user. Normally the UserDisplayName column shows the first and last name of the employee associated with that activesync device. Today, however, I noticed that, for one of the entries, the employee name in the UserDisplayName column has been replaced by NAMPR02A002.prod.outlook.com. Ran a Google search but could find nothing on this. Has anyone encountered this before? If so, what causes it?

  • #104302

    Keymaster
    Points: 1,704
    Helping HandTeam Member
    Rank: Community Hero

    Not reeeeally a PowerShell question so much as an Exchange one, but I'll guess that the device in question isn't associated with a user?

  • #104306

    Participant
    Points: 0
    Rank: Member

    Don, that's what I thought but the identity field shows the employee's name. So, on some level, Activesync sees this device as associated with a particular user.

    Sorry if I posted this in the wrong forum.

  • #104309

    Keymaster
    Points: 1,704
    Helping HandTeam Member
    Rank: Community Hero

    No need to apologize – it's just that I'm not sure you'll get a good answer here. Totally understand that you're using PowerShell, but the problem is in Exchange/ActiveSync itself, and I in particular just am not a guru on those products. I don't know if there's an Exchange forum out there that might be more useful, but of course we can see if someone with more Exchange knowledge jumps in here.

    This is what I always tell folks – PowerShell's easy. It's all the stuff PowerShell "touches" that's hard [grin].

  • #104315
    Jon

    Participant
    Points: 36
    Rank: Member

    It's doing the same thing for me.

    I would open a ticket with MS.

The topic ‘Get-MobileDevice cmdlet showing odd UserDisplayName’ is closed to new replies.