Getting error while trying to run Install-Module -Name az -Force

Welcome Forums General PowerShell Q&A Getting error while trying to run Install-Module -Name az -Force

Viewing 1 reply thread
  • Author
    Posts
    • #222042
      Participant
      Topics: 1
      Replies: 0
      Points: -8
      Rank: Member

      I am trying to upgrade my Az powershell module from 3.1 to 3.8.0 and i get the error as shown below. I tried the same from VS Code, still the same. Can anyone help me to fix this please

      PS C:\Users\palchakraborty> install-module -Name az -force
      Install-Package: C:\Users\palchakraborty\Documents\PowerShell\Modules\PowerShellGet\2.2.4.1\PSModule.psm1:9709
      Line |
      9709 | … talledPackages = PackageManagement\Install-Package @PSBoundParameters
      | ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
      | The module ‘Az.Accounts’ cannot be installed or updated because the authenticode signature of the file ‘Az.Accounts.psd1’ is not valid.

      PS C:\Users\palchakraborty>

    • #223551
      Participant
      Topics: 3
      Replies: 324
      Points: 1,056
      Helping Hand
      Rank: Community Hero

      Are you able to update other modules?

Viewing 1 reply thread
  • You must be logged in to reply to this topic.