How to add Active Directory module in PowerShell in Windows 10?

This topic contains 5 replies, has 5 voices, and was last updated by Profile photo of Peter Jurgens Peter Jurgens 1 year, 2 months ago.

  • Author
  • #28474
    Profile photo of Philiz

    I've installed Remote Server Administration Tools for Windows 10 Technical Preview (January 2015) but no dice. Anybody knows how to do this? I'm using Win 10 Pro.

    Many thanks!

  • #28475
    Profile photo of Daniel Krebs
    Daniel Krebs

    The Windows 10 RTM compatible Remote Server Administration Tools will be released later this month along with Windows Server 2016 Technical Preview 3.

    Please check out Mike F. Robbins blog post about a possible workaround for you until the RTM compatible tools have been made available.

  • #28477
    Profile photo of Philiz

    Ok, thx!!

  • #28479
    Profile photo of Mike F Robbins
    Mike F Robbins

    This may help you get by until the updated RSAT tools are released: Using PowerShell for Remote Server Administration in Windows 10 RTM without the RSAT tools

    (I didn't realize Daniel had already posted a link to this. Thanks Daniel)

  • #28481
    Profile photo of Bob McCoy
    Bob McCoy

    Implicit remoting is one of the great hidden treasures of PowerShell.

  • #28482
    Profile photo of Peter Jurgens
    Peter Jurgens

    I posted a comment on your blog post mike but wanted to post in here to see if any others had comments here.

    Without having tried using export-pssession, simply using implicit remoting, I find that I run into issues with deserialization and the cmdlets won't work well together like piping get-adgroup | get-adgroupmember gives me a type error. Do you encounter similar? Or perhaps it could be due to the fact that my DC is still running v2 PoSh? Another option I haven't been successful with yet was implicit remoting to another 2012 r2 server that I have with RSAT installed. Last time I tried I encountered issues with delegated credentials. But then I didn't attempt to resolve that issue yet either… Maybe I have some testing to do and get back…

You must be logged in to reply to this topic.