How-to make DSC not to utilize 100% CPU while it gets executed.

Welcome Forums DSC (Desired State Configuration) How-to make DSC not to utilize 100% CPU while it gets executed.

This topic contains 4 replies, has 2 voices, and was last updated by

 
Participant
3 years, 1 month ago.

  • Author
    Posts
  • #30546

    Participant
    Points: 0
    Rank: Member

    I'm having a situation, when DSC gets executed and utilize 100% of the CPU for it's execution time, in most cases lasts less than a minute. But unfortunately this affects running application. So I'd like to know are there any way to restrict DSC CPU usage. Also maybe someone have experienced the same situation can you please share on how-to solve this.

  • #30571

    Keymaster
    Points: 1,619
    Helping HandTeam Member
    Rank: Community Hero

    There is not.

    However, it might be worth using the DSC Diagnostics module to enable a trace before the LCM runs next time. Reviewing the event logs. after disabling the trace, might show you why the processor usage is so high. For example, if the configuration is having the LCM do something especially taxing, you could look at removing that part of the configuration to see if it makes any difference.

    Basically – basic troubleshooting :).

  • #30722

    Participant
    Points: 0
    Rank: Member

    By following your suggestion I've figured out, that WMI provider"deploymentprovider" which is a part of ServerManager.DeploymentProvider.dll and is used to test/set WindowsFeature DSC resource cause 60-70% CPU usage. Haven't found any issue and still looking for some help to troubleshoot this.

  • #30729

    Keymaster
    Points: 1,619
    Helping HandTeam Member
    Rank: Community Hero

    That's something you should submit as a support ticket to Microsoft, then. There's nothing you can do to fix it – they'd need to.

  • #30911

    Participant
    Points: 0
    Rank: Member

    Final results I've got. Maybe this will be useful for somebody.

The topic ‘How-to make DSC not to utilize 100% CPU while it gets executed.’ is closed to new replies.