IE com object with Win 7 IE 9 doesn't work

Welcome Forums General PowerShell Q&A IE com object with Win 7 IE 9 doesn't work

This topic contains 1 reply, has 2 voices, and was last updated by

 
Keymaster
5 years, 1 month ago.

  • Author
    Posts
  • #10840

    Participant
    Points: 0
    Rank: Member

    Guys,

    I had a script for the application L1 team in my Org who use to monitor a application login using a powershell automation. I used the following concept.
    http://msdn.microsoft.com/en-us/magazine/cc337896.aspx
    However, recently we had a Win 7 Upgrade for all L1 Staffs. And since then this script has stopped working.
    I digged into the script and Found out that the issue is with when you do;
    $ie.Navigate($url)
    This completely makes the object blank!. I tried launching PS in Run as Admin and it worked.
    However this will not work for the L1 team as they won't have Admin access to the kiosk they work on. This is a major issue now. I am game completely rewriting the script, however haven't had a success yet. I found there is a WebBrowser class in System.Windows.Forms namespace, not sure if this will work.
    Any Advise is helpful.

  • #10849

    Keymaster
    Points: 1,638
    Helping HandTeam Member
    Rank: Community Hero

    The WebBrowser class is something to try; it's pretty different in that it doesn't control a separate IE window, though. It sounds like you're simply running into a security issue. Windows 7 is a lot more security-segmented than Windows XP was, so I'm not surprised.

The topic ‘IE com object with Win 7 IE 9 doesn't work’ is closed to new replies.