Import-Module : The specified module 'failoverclusters' was not loaded

This topic contains 1 reply, has 2 voices, and was last updated by Profile photo of Jonathan Warnken Jonathan Warnken 8 months, 2 weeks ago.

  • Author
    Posts
  • #36882
    Profile photo of Brett Reed
    Brett Reed
    Participant

    Trying to import the failoverclusters module and the module can't be found.
    windows 2008 R2
    the user account is a local admin. it runs fine when executing locally, it will not run when run from CA Autosys. i can also replicate the error locally
    this runs correctly locally with the same user
    C:\Windows\system32\WindowsPowerShell\v1.0\powershell.exe .\BackupCleanup.ps1

    but if i run this i can recreate the error from autosys.
    c:\WINDOWS\SysWOW64\windowspowershell\v1.0\powershell.exe .\BackupCleanup.ps1

    NOTE neither work from within autosys

    the error is
    Import-Module : The specified module 'failoverclusters' was not loaded because
    no valid module file was found in any module directory.
    if i do a DIR while executing the failed script note the module is missing.
    Directory: C:\Windows\System32\WindowsPowerShell\v1.0\Modules
    Mode LastWriteTime Length Name
    —- ————- —— —-
    d—s 11/21/2010 12:46 AM BitsTransfer
    d—- 7/14/2009 1:37 AM PSDiagnostics
    d—- 11/21/2010 12:46 AM TroubleshootingPack

    when i try to alter permissions of the module folder i get an error.

  • #36884
    Profile photo of Jonathan Warnken
    Jonathan Warnken
    Participant

    I do not have a way to validate it at the moment but is appears that the module requires you to be running as a 64 bit process and the Autosys parent is 32 bit. you can try launching powershell with this command

    %windir%\sysnative\windowspowershell\v1.0\powershell.exe

You must be logged in to reply to this topic.