LCM settings

This topic contains 5 replies, has 4 voices, and was last updated by Profile photo of Bjørn Roalkvam Bjørn Roalkvam 3 months ago.

  • Author
    Posts
  • #52069
    Profile photo of Bjørn Roalkvam
    Bjørn Roalkvam
    Participant

    Hi, using Server 2012R2 WMF 5.

    I have a LCM configuration that looks like this:

    
    #---------------------------------
    #CONFIGURE LCM
    #---------------------------------
    #Bruker registrationkey fra over.
    [DSCLocalConfigurationManager()]
    configuration PullClientConfigID
    {
            param (
            [Parameter(Mandatory=$true)] [ValidateNotNullOrEmpty()] [array] $NodeName,
            [Parameter(Mandatory=$true)] [ValidateNotNullOrEmpty()] [string] $PullServer,
            [Parameter(Mandatory=$true)] [ValidateNotNullOrEmpty()] [string] $NodeThumbprint,
            [Parameter(Mandatory=$true)] [ValidateNotNullOrEmpty()] [string] $RegistrationKey
        )
    
    
        Node $NodeName
        {
            Settings
            {
                RefreshMode          = 'Pull'
                RefreshFrequencyMins = 90 
                RebootNodeIfNeeded   = $true
                AllowModuleOverwrite = $true
                ConfigurationMode = "ApplyAndAutocorrect"
                CertificateID = $NodeThumbprint
    
            }
    
            ConfigurationRepositoryWeb PullSrv
            {
                ServerURL          = "https://$PullServer"+":8080/PSDSCPullServer.svc"
                RegistrationKey    = $RegkeyFromLocation
    
                ConfigurationNames = @('SQLSharePointInstall')
            }   
    
            ReportServerWeb PullSrv
            {
                ServerURL       = "https://$PullServer"+":8080/PSDSCPullServer.svc"
                RegistrationKey = $RegkeyFromLocation
            }
    
            ResourceRepositoryWeb PullSrv
            {
                ServerURL = "https://$PullServer"+":8080/PSDSCPullServer.svc"
                RegistrationKey = $RegkeyFromLocation
            }
    
        }
    } 

    Running this remotely on my node, updates my node to:

    ActionAfterReboot              : ContinueConfiguration
    AgentId                        : B9089C01-6470-11E6-80D9-005056834AFD
    AllowModuleOverWrite           : True
    CertificateID                  : 4CE00B7329DE171E606243CD32A9D819585368A9
    ConfigurationDownloadManagers  : {[ConfigurationRepositoryWeb]PullSrv}
    ConfigurationID                : 
    ConfigurationMode              : ApplyAndAutoCorrect
    ConfigurationModeFrequencyMins : 15
    Credential                     : 
    DebugMode                      : {NONE}
    DownloadManagerCustomData      : 
    DownloadManagerName            : 
    LCMCompatibleVersions          : {1.0, 2.0}
    LCMState                       : Idle
    LCMStateDetail                 : 
    LCMVersion                     : 2.0
    StatusRetentionTimeInDays      : 10
    PartialConfigurations          : 
    RebootNodeIfNeeded             : True
    RefreshFrequencyMins           : 90
    RefreshMode                    : Pull
    ReportManagers                 : {[ReportServerWeb]PullSrv}
    ResourceModuleManagers         : {[ResourceRepositoryWeb]PullSrv}
    PSComputerName                 :  

    My understanding is that the ConfigurationDownloadManagers,ReportManagers and ResourceModuleManagers are obsolete in V5 (Ref Don Jones book DSC Book P:47/110).

    Why are these settings then filled with LCM configuration data? Just showing the data and will be removed in the future?
    Or maybe my LCM configuration is out of date? 🙂

    Brgs

    Bjørn

  • #52159
    Profile photo of Don Jones
    Don Jones
    Keymaster

    No, they're not obsolete. I got the names mixed up in the book and am correcting that in the next update.

  • #52173
    Profile photo of Arie H
    Arie H
    Participant

    As noted in my answer to your previous post, if you're using the same pull server for Configuration/Report and for Resources, you don't need the last section of your script: ResourceRepositoryWeb PullSrv

  • #52230
    Profile photo of Bjørn Roalkvam
    Bjørn Roalkvam
    Participant

    Alright thanks!

    Brgs

    BJørn

  • #53617

    Hi Bjorn,
    Is your issue resolved now?
    Thanks,
    Indhu

  • #53710
    Profile photo of Bjørn Roalkvam
    Bjørn Roalkvam
    Participant

    Hi Indhu,

    Issue is resolved thank you.

    Brgs

    Bjørn

You must be logged in to reply to this topic.