Module Manifest

This topic contains 1 reply, has 1 voice, and was last updated by Profile photo of Bojan Zivkovic Bojan Zivkovic 5 months, 3 weeks ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #37224
    Profile photo of Bojan Zivkovic
    Bojan Zivkovic
    Participant

    Having created module manifest for module Tools (Tools.psm1 module file, Tools.psd1 manifest file in the same module folder) ten days ago I noticed that functions latter added to module can not be recognized although they are listed with:

    Get-Command -Module Tools -Type Function

    I have to manually remove (it is normal to do after any change) and import module (this should not have been done – autoloading should have worked) manually each time I change existing or create additional functions in Tools module even though it is located where it should be in order for autoloading to work:

    $env:USERPROFILE\Documents\WindowsPowerShell\Modules\Tools\

    Also autoloading of functions in other modules located in $env:USERPROFILE\Documents\WindowsPowerShell\Modules\ModuleName does not work. Naming of .psm1 and .psd1 files is correct – same name of file as module folder name. Before creating module manifest for module Tools autoloading worked flawlessly.

    #37225
    Profile photo of Bojan Zivkovic
    Bojan Zivkovic
    Participant

    I have no idea what is going on here. Having deleted Tools.psd1 file autoloading of some modules works and of others does not. This is difficult to troubleshoot.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.