Mount Point Folder Not Found

Welcome Forums DSC (Desired State Configuration) Mount Point Folder Not Found

This topic contains 1 reply, has 1 voice, and was last updated by

AK
 
Participant
1 month, 3 weeks ago.

  • Author
    Posts
  • #118906
    AK

    Participant
    Points: 14
    Rank: Member

    Hello Everyone,

     

    I'm having this strange problem where the below section generates an error on the first run (push mode). Subsequent runs execute without issues. Directory gets created, but the step that maps volume to a folder can't use it for whatever reason. Tried adding 10 seconds delay – no go.

     

    PSVersion 5.1.14393.2515

    File MountDirSQLData
    {
    Ensure ="Present"
    Type ="Directory"
    DependsOn = '[Disk]MountPoint'
    DestinationPath = "U:\Data"
    }
    WaitforDisk DataDisk
    {
    DiskId = $Node.DataDisk
    RetryIntervalSec = 60
    RetryCount = 5
    DependsOn = '[Disk]MountPoint'
    }
    DiskAccessPath DataVolume
    {
    DiskId = $Node.DataDisk
    AccessPath = 'U:\Data'
    DependsOn = '[File]MountDirSQLData'
    AllocationUnitSize = 64KB
    FSLabel = 'Data'
    }

    Error message:

    
    PowerShell DSC resource MSFT_DiskAccessPath  failed to execute Test-TargetResource functionality with error message: Access Path 'U:\Data' is not found.
    
    Parameter name: AccessPath
    
    + CategoryInfo          : InvalidOperation: (:) [], CimException
    
    + FullyQualifiedErrorId : ProviderOperationExecutionFailure
    
    

    Any help would be appreciated.

  • #119254
    AK

    Participant
    Points: 14
    Rank: Member

    Appears to be a bug in the module. Someone appears to be working on it, but it has not been resolved:

    https://github.com/PowerShell/StorageDsc/issues/121

You must be logged in to reply to this topic.