Need Help with Remoting?

This topic contains 0 replies, has 1 voice, and was last updated by  Forums Archives 5 years, 9 months ago.

  • Author
    Posts
  • #6104

    by hkang at 2013-01-03 06:08:46

    I have recently upgraded my windows 7 computer to Powershell 3.0 (from 2.0) and connect to the Exchange 2010 by implicit remoting into Exchange to run Exchange powershell commands.
    The problem I am experiencing is that the help for Exchange commands are not working correctly now. Prior to upgrading to PS 3.0, help was working just fine but now if I type "help get-mailbox -example" nothing returns (just empty spaces but no errors). This is true for all Exchange commands. The imported Active directory module HELP commands work correctly so this is happening only to Exchange commands. Also, if I change to PS version 2.0 by typing the command "Powershell -version 2.0", help for Exchange commands work correctly. This behavior is only present in PS version 3.
    Anything I should check?
    Thank you in advance.

    by powerschill at 2013-01-03 06:23:17

    I believe the issue you might be encountering is because Exchange doesn't support PowerShell v 3.0. You might want to look at this article for more information: https://blogs.technet.com/b/exchange/archive/2012/12/14/windows-management-framework-3-0-on-exchange-2007-and-exchange-2010.aspx?Redirected=true

    by hkang at 2013-01-03 19:17:16

    Thank you for the quick response. Until the Exchange SP3, I guess I can always use the "help get-mailbox -online" in PS 3.

    by DonJ at 2013-01-03 19:23:29

    It might not. If you don't have the help file installed locally, then there's no local definition for where to find the online help. There isn't one uber-site where all help lives – every command's help file defines the location for its online help.

    I'm surprised implicit remoting isn't working. I'd thought the issue was just having 3.0 on the server. Weird. Wonder what the underlying details are behind that.

    by hkang at 2013-01-07 08:54:27

    Actually, implicit remoting to the Exchange server works fine – I can use all the Exchange 2010 commands from my PS 3.0 on Windows 7 Enterprise. The only issue is the help for the Exchange commands, specifically, for example "Get-help set-distributionGroup -example" — this will return 3 empty lines and no examples. If I type "Get-help Set-DistributionGroup" then I get Synopsis, Syntax, Description, Related Links and Remarks. If I type, "Get-Help Set-DistributionGroup -Detailed" then I only get Syntax, Description, Parameters and Remarks but Syntax and Description are empty.
    When I type "Get-Help Set-DistributionGroup -Online" then it takes me straight to the microsoft technet site's library and shows the online help of the command which is what I've been doing as a workaround.
    Thanks.

    by ArtB0514 at 2013-01-07 10:37:57

    Implicit remoting from PowerShell 3 to PowerShell 2 (i.e., Exchange 2010 Management Shell) works just fine, but there's no updatable help module for the older version (at least not yet). The only viable help is the -OnLine help. Alternatively, you can bookmark http://technet.microsoft.com/en-us/library/bb123778(v=exchg.141).aspx, which is the Exchange 2010 Managment Shell home page.

    by mjolinor at 2013-03-03 08:14:39

    BTDT

    If you use Powershell -version 2.0 before you do the session import, Help works again (but you lose all the V3 goodness).

    If you mostly use get-help for the Exchange cmdlets, you make -Online the default for Get-Help by setting $PSDefaultParameterValues for that in your profile.

You must be logged in to reply to this topic.