New-DfsReplicatedFolder Failing over remote powershell

This topic contains 1 reply, has 1 voice, and was last updated by  Tom Vernon 1 year, 9 months ago.

  • Author
  • #43006

    Tom Vernon

    Hello All,

    Im trying to run this command via remote powershell. When I run it locally it works fine but over a remote powershell session I get an unuseful error message:

    New-DfsReplicatedFolder -GroupName TESTGROUP -FolderName TEST
    Invoke-Command -Session $FSSession -ScriptBlock {param($Name) New-DfsReplicatedFolder -GroupName TESTGROUP -FolderName ${Name} } -Args $Name

    I just get this error message and nothing else logged:

    Could not create the replicated folder named "Test99" in the replication group named "TESTGROUP". An operation error occurred.
        + CategoryInfo          : NotSpecified: (System.String[]:String[]) [New-DfsReplicatedFolder], DfsrException
        + FullyQualifiedErrorId : New-DfsReplicatedFolder.TerminatingOMException,Microsoft.DistributedFileSystemReplication.Commands.NewDfsReplicatedFolderCommand
        + PSComputerName        :

    Any ideas why this wouldnt be working over a remote powershell session? Scratching my head with this one!


    • This topic was modified 1 year, 9 months ago by  Tom Vernon.
  • #43082

    Tom Vernon

    Strangely, I've noticed that all DFSR commands fail with the same error, even though the DFSR module has been imported.

You must be logged in to reply to this topic.