New-PSSession fails with "server name cannot be resolved" with 64 bit PS Console

This topic contains 2 replies, has 3 voices, and was last updated by Profile photo of Kieran Jacobsen Kieran Jacobsen 1 year ago.

  • Author
  • #30362
    Profile photo of selko

    i have the problem that if i run New-PSSession -Computername xxxx the command fails with a 64 bit PS Console:

    New-PSSession : [xxxx] Connecting to remote server xxxx failed with the following error message : The WinRM client cannot processthe request because the server name cannot be resolved. For more information, see the about_Remote_Troubleshooting Help topic.

    I can resolve xxxx with a DNS query.

    If i run the command with a 32 bit PS Console it works fine...

    Do you have any ideas why this is so?


  • #30388
    Profile photo of Jonathan Warnken
    Jonathan Warnken

    I don't know of an easy answer for you. You have to work through the name resolution. Start with a

    Test-Connection XXXX 

    If that is successful try specific ports and work through possible options.

  • #30394
    Profile photo of Kieran Jacobsen
    Kieran Jacobsen

    What is Resolve-DNSName giving you in a 64bit PS console?

You must be logged in to reply to this topic.