New user – I’m unable to do update-help

Welcome Forums General PowerShell Q&A New user – I’m unable to do update-help

Viewing 3 reply threads
  • Author
    Posts
    • #239612
      Participant
      Topics: 1
      Replies: 0
      Points: 11
      Rank: Member

      Evening all!

      I’m trying to get into PowerShell to automate some tasks in work (I am an IT Support Analyst and could use with some automation).

       

      I was looking at the MVA videos and when I try to run update-help, I always get an error. Error is below 🙂

      update-help : Failed to update Help for the module(s) ‘ConfigDefender, Microsoft.WSMan.Management, PSReadline, WindowsUpdateProvider’ with UI culture(s) {en-GB} : Unable to retrieve the
      HelpInfo XML file for UI culture en-GB. Make sure the HelpInfoUri property in the module manifest is valid or check your network connection and then try the command again.
      At line:1 char:1
      + update-help
      + ~~~~~~~~~~~
      + CategoryInfo : ResourceUnavailable: (:) [Update-Help], Exception
      + FullyQualifiedErrorId : UnableToRetrieveHelpInfoXml,Microsoft.PowerShell.Commands.UpdateHelpCommand

       

      I have looked up some articles before coming here and I have tried to solve this issue my self however I am unable too.

       

      Does anyone have any advice? 🙂

       

    • #239627
      Participant
      Topics: 7
      Replies: 2458
      Points: 6,439
      Helping Hand
      Rank: Community MVP

      Does anyone have any advice? 🙂

      Ignore it and use the online help. That will save you from a lot of wasted time. 😉

    • #240311
      Participant
      Topics: 6
      Replies: 20
      Points: 68
      Helping Hand
      Rank: Member

      Try update-help with -uiculture set to your specific culture en-GB

      update-help -uiculture en-GB

      If the above didn’t solve your problem, set your culture to en-US then update help.

      • This reply was modified 2 months, 3 weeks ago by Gnart.
      • This reply was modified 2 months, 3 weeks ago by Gnart.
    • #240470
      Participant
      Topics: 0
      Replies: 1
      Points: 5
      Rank: Member

      I’m having the exact same issue except en-US. I tried running it with the uiculture parameter set to en-US, with no luck.

Viewing 3 reply threads
  • You must be logged in to reply to this topic.