Node registration in WMF5 April

Welcome Forums DSC (Desired State Configuration) Node registration in WMF5 April

This topic contains 3 replies, has 2 voices, and was last updated by

 
Participant
3 years, 5 months ago.

  • Author
    Posts
  • #26798

    Participant
    Points: 0
    Rank: Member

    I followed this blog http://blogs.msdn.com/b/powershell/archive/2015/05/29/how-to-register-a-node-with-a-dsc-pull-server.aspx to set up the LCM.

    Set-DscLocalConfigurationManager and got this error.

    The attempt to register Dsc Agent with AgentId B74A405E-153E-11E5-80C0-000C29C23BD5 with the server
    http://xxxxx:8080/PSDSCPullServer.svc/Nodes(AgentId='B74A405E-153E-11E5-80C0-000C29C23BD5') returned unexpected response code NotFound.
    + CategoryInfo : InvalidResult: (root/Microsoft/...gurationManager:String) [], CimException
    + FullyQualifiedErrorId : RegisterDscAgentUnsuccessful,Microsoft.PowerShell.DesiredStateConfiguration.Commands.RegisterDscAgentCommand

    I have RegistrationKeys.txt that contains the GUID. Is it the way it should be?

    B74A405E-153E-11E5-80C0-000C29C23BD5
    2cfe8756-7d19-46b5-ab98-b59ec0a87259
    

    Another thing is that the metamof actually has

    RegistrationKey = "2cfe8756-7d19-46b5-ab98-b59ec0a87259";

    The B74A405E-153E-11E5-80C0-000C29C23BD5 in the error is the existing one on the node.

    Thank you!

  • #26808

    Participant
    Points: 0
    Rank: Member

    I got the same error

    any luck with the answer?

  • #26870

    Participant
    Points: 0
    Rank: Member

    YES! I re-configure the Pull Server Web Service by manually delete the site and reconfigure it with xDscWebService. Mine was created in WMF5 Feb and there are changes to it in WMF5 April.

    And I think the change is the method/verb that web service are providing.

    The new one has Nodes which is in the error message Not Found.

    See the available method using http://localhost:8080/PSDSCPullServer.svc/.

  • #27138

    Participant
    Points: 0
    Rank: Member

    I Managed to solve it with your suggestion

    Thanks!!!

The topic ‘Node registration in WMF5 April’ is closed to new replies.