Node StatusData history being removed from Pull server

This topic contains 2 replies, has 2 voices, and was last updated by Profile photo of Arie H Arie H 5 months, 3 weeks ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #37111
    Profile photo of Cory Wood
    Cory Wood
    Participant

    We have a node running WMF 5 configured using DSC in Push mode with the ConfigurationMode set to ApplyOnly. This node is registered with a Pull server also running WMF 5 for reporting only.

    When we run the DSC configuration, we can see that the StatusData is sent to the Pull server by following the steps at https://msdn.microsoft.com/en-us/powershell/dsc/reportserver or by opening the "C:\Program Files\WindowsPowerShell\DscService\Devices.mdb" file and viewing the data directly.

    However, this data is getting wiped out in under a day, so if we start a DSC configuration one day and come back the next day to check the status, the history is gone.

    Is there any way to configure the length of time that a Pull server keeps reporting history in the Devices.mdb database?

    #37196
    Profile photo of Arie H
    Arie H
    Participant

    Hi Cory,

    I've seen days with 30reports, and days with 100+. Couldn't yet understand the logic or see ways I can control it.

    Remember that all data is also on the node itself in the event logs, so you can query that.

    You could try to increase time for consistency checks in the lcm settings and see if it records more.

    Other then that, there's the two new lcm properties, LCMState and LCMStateDetails iirc that you can query in real time.

    I can imagine, not tested, there's a wmi event that you can register to and get notified. To me it seems the report server is still "fresh" and not yet fully implemented but it gives some info and a step in good direction

    #37197
    Profile photo of Arie H
    Arie H
    Participant

    Double post, sorry. Can't delete it, it seems. 😊

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.