Author Posts

May 31, 2017 at 8:48 pm

Doing something wrong here. It hangs at this part.

VERBOSE: [server]: [[Package]Splunk] Package configuration starting
VERBOSE: [server]: [[Package]Splunk] Starting C:\Windows\system32\msiexec.exe with /i
"C:\windows\Temp\splunk.msi" /quiet INSTALLDIR='C:\Program Files\SplunkUniversalForwarder' AGREETOLICENSE=Yes /QUIET
VERBOSE: [server]: [[Package]Splunk] Starting process C:\Windows\system32\msiexec.exe
with arguments /i "C:\windows\Temp\splunk.msi" /quiet INSTALLDIR='C:\Program Files\SplunkUniversalForwarder'
AGREETOLICENSE=Yes


Package Splunk
         {
            Ensure = 'Present'
            Name = 'UniversalForwarder'
            Path = 'C:\windows\Temp\splunk.msi'
			Arguments = "INSTALLDIR='C:\Program Files\SplunkUniversalForwarder' AGREETOLICENSE=Yes"
            ProductId = 'A3FA04AC-2CF4-4AC5-96A5-1D954080A78E'
			
         }
		
		

June 1, 2017 at 12:24 am

We tried this in the PowerShell team, but we're blocked due to not being able to register with Splunk right now.
Can you try installing the MSI outside of Package Management, and describe what you are seeing?

Thank you

June 1, 2017 at 11:59 am

When I execute the command in powershell it pops up the msiexec help box. If I switch to cmd it installs. I removed the /i and /quiet from the arguments as dsc automatically includes them.

msiexec popup

PS C:\Windows\system32> msiexec.exe /i c:\windows\temp\splunk.msi INSTALLDIR="c:\program files\SplunkUniversalForwarder"
AGREETOLICENSE=Yes /quiet

installs quietly

PS C:\Windows\system32> cmd
Microsoft Windows [Version 6.3.9600]
(c) 2013 Microsoft Corporation. All rights reserved.

C:\Windows\system32>msiexec.exe /i c:\windows\temp\splunk.msi INSTALLDIR="c:\program files\SplunkUniversalForwarder" AGR
EETOLICENSE=Yes /quiet