POSREADY 7 - Powershell 3 - can't get it to install

Welcome Forums General PowerShell Q&A POSREADY 7 - Powershell 3 - can't get it to install

This topic contains 2 replies, has 3 voices, and was last updated by

 
Member
4 years, 8 months ago.

  • Author
    Posts
  • #14329

    Participant
    Points: 90
    Rank: Member

    I feel like I must be missing something – but I am trying to install powershell 3 on a posready 7 machine. It has SP1 installed. I went through the blog post at http://blogs.technet.com/b/heyscriptingguy/archive/2013/06/02/weekend-scripter-install-powershell-3-0-on-windows-7.aspx – and it isn't working. Once I installed .net 4, the update successfully ran (Windows6.1-KB2506143-x86.msu). It never prompted me for a reboot, but I rebooted anyways. Now I run my powershell and I still see version 2. I have checked both with $psversiontable and $host.version.

    Will powershell 3 run on POSREADY 7?

  • #14331

    Keymaster
    Points: 1,673
    Helping HandTeam Member
    Rank: Community Hero

    I'm not familiar with that operating system. I do know that you need to make sure you installed the FULL .NET Framework, not the "client profile," but you'll have to check with the operating system folks to see if they support Windows PowerShell on it.

  • #14332

    Member
    Points: 0
    Rank: Member

    It looks like maybe there's a different method for installing on Windows Embedded (POSReady). I found this blog post which mentions Windows Management Framework 4.0 on that platform, and there are probably older posts for v3.0: http://blogs.msdn.com/b/windows-embedded/archive/2014/01/08/december-2013-feature-updates-are-available-on-myoem-for-posready7.aspx . The link, however, is for OEMs. I don't know if there's a way for customers to download the update directly, but you can always contact the vendor that supplied your POS system for assistance.

The topic ‘POSREADY 7 - Powershell 3 - can't get it to install’ is closed to new replies.