Powershell 7 and the Get-ACEData module

Welcome Forums General PowerShell Q&A Powershell 7 and the Get-ACEData module

Viewing 0 reply threads
  • Author
    Posts
    • #209016
      Participant
      Topics: 86
      Replies: 138
      Points: 677
      Rank: Major Contributor

      I just installed the recently released Powershell 7.  I installed the Microsoft Access Redistributable Engine 2016 (64-bit) version, then imported the ACE module. All worked accordingly.   To confirm, I typed:

       help get-ACEData -full

      and the response checked out, per documentation.

      However, the following lines of code, which are the first to be executed in my old (i.e., Powershell 5.1) script which have worked perfectly in the last 2 years, no longer work under Powershell 7:

       $q = Get-ACEData -Filepath $DBLoc -Table Jobworked -Query $QUERY2
      
      $x = $q.$Tables[0].Rows[0]
      I get the message:
      InvalidOperation:  C:\Users\... <my specifics, omitted>
      $x = $q.$Tables[0].Rows[0]
      ~~~~~~~~~~~~~~~~~~~~
      Cannot index into a null array.
      Would appreciate some tips or guidance.  My searches so far with the ACCESS database side have come up empty.  Because those 2 lines of PS code still work under v5.1, I must be missing some PS 7 requirements.
      I understand that in some sense, v5.1 is “ended” and that PS 6 and onwards (to PS 7 today) are a rather completely different platform.  But if you happen to have some tips to share, workarounds, etc., I’d appreciate the help.
      Thanks,
      • This topic was modified 5 months ago by Ramon TAN.
Viewing 0 reply threads
  • The topic ‘Powershell 7 and the Get-ACEData module’ is closed to new replies.