Author Posts

September 21, 2016 at 1:54 am

I have Windows 10 and enabled hyper-v.

I am trying to connect to a VM that is running locally and not joined to the domain

heres my code:

Enter-PSSession -VMName 'ref001' -Credential (Get-Credential "$env:COMPUTERNAME\Hman")

And the error .... any help would be great . Thank you

Enter-PSSession : An error has occurred which Windows PowerShell cannot handle. A remote
session might have ended.
At line:1 char:1
+ Enter-PSSession -VMName 'ref001' -Credential (Get-Credential "$env:CO ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : ResourceUnavailable: (:) [Enter-PSSession], PSRemotingData
StructureException
+ FullyQualifiedErrorId : System.Management.Automation.Remoting.PSRemotingDataStruct
ureException,Microsoft.PowerShell.Commands.EnterPSSessionCommand

  • This topic was modified 1 year, 12 months ago by  H Man.
  • This topic was modified 1 year, 12 months ago by  H Man.

September 21, 2016 at 2:19 am

Because the VM is not joined to a domain, you need to manually add the host name of the VM to the TrustedHosts list on your Windows 10 computer. This should resolve the issue, given that the VM and your Windows 10 system are on the same network.

Set-Item WSMan:\localhost\Client\TrustedHosts -Value 'ref001' -Concatenate

Once that is done you need to also ensure that PSRemoting is enabled on the VM which will take care of all the WinRM, opening firewall ports, etc.

September 21, 2016 at 2:55 am

I just tried it , and I am still getting the error..

it is also requiring a credential , while the cmdlet without the -vmname does not? BUG?

  • This reply was modified 1 year, 12 months ago by  H Man.

September 21, 2016 at 3:09 am

There may be better approaches but it appears your Enter-PSSession is using a credential from your computer's local session rather than authenticating against a local account on the VM (I assume that's what you need to do).

Try this:

Enter-PSSession -VMName 'ref001' -Credential (Get-Credential "[VMHostName]\[LocalAccountName]")

September 21, 2016 at 3:32 am

great idea , but still the same error... im baffled

September 21, 2016 at 4:55 am

Are you up for using -ComputerName instead of -VMName?

September 21, 2016 at 10:57 am

no i am using -VMName

August 16, 2017 at 1:44 pm

Go into your Hyper-V-Manager. Right Click on your VM, go to Settings, Integration Services. Make sure they are all Activated.