PowerShell install of SQL Server Data Tools fails, works manually

This topic contains 3 replies, has 3 voices, and was last updated by Profile photo of Max Kozlov Max Kozlov 1 week ago.

  • Author
    Posts
  • #70780
    Profile photo of J
    J
    Participant

    I'm installing SQL Data Tools via a PowerShell script. I run my script, but the final part where the Data Tools are installed fails (inside of the SQL installer window). If I run the script without that part, and install Data Tools manually it works.

    The error is:

    VS Shell installation has failed with exit code -2147205120.

    The parts before this install .NET, SQL Server Management Studio, and SQL SP1. I don't think they're relevant to my issue, but I will post that part if requested. Here are the relevant parts. This should install Data Tools and SNAC_SDK.

    try
    {
    Write-Host "Lauching SQL Server Data Tools install ..."
    & "\\mynetworkpath\SSDTBI_x86_ENU.exe" "/ACTION=INSTALL" "/FEATURES=SSDTBI,SNAC_SDK" "/Q" "/IACCEPTSQLSERVERLICENSETERMS"
    Write-Host "Installer launched ..."
    }
    catch
    {
    Write-Host "SQL Server Data Tools installation failed"
    exit
    }

    As it is now, it finishes the install with that error I posted, and has installed Visual Studio, but no Data Tools.

    If I run the installer manually (and check the two boxes for SSDT and SNAC_SDK) everything installs correctly.

    So the PowerShell installer is working... half way...

  • #70786
    Profile photo of Don Jones
    Don Jones
    Keymaster

    That's a "poorly built installer" problem. It's probably not something you can fix.

    • #70787
      Profile photo of J
      J
      Participant

      Really? What makes you say that?

  • #70880
    Profile photo of Max Kozlov
    Max Kozlov
    Participant

    may be your error code means something similar to 'Block' ?
    https://msdn.microsoft.com/en-us/library/ee225238.aspx

You must be logged in to reply to this topic.