Powershell v3 for Home Premium?

This topic contains 0 replies, has 1 voice, and was last updated by Profile photo of Forums Archives Forums Archives 5 years, 3 months ago.

  • Author
    Posts
  • #5257

    by figueroa2david at 2012-11-02 20:38:10

    Is there a way to get this? I downloaded the 4 versions i could find from Microsoft, and they all come up with "not applicable"..

    Thanks,

    David F.

    by mikefrobbins at 2012-11-02 20:45:40

    Install the .NET framework 4.0 first otherwise you'll receive that error even if it's the right version.

    a user uploaded image

    by coderaven at 2012-11-02 20:47:25

    What version of Windows? XP, Vista, 7?

    PowerShell 3 is only for WIndows 7/Server 2008 R2; Windows 8 / Server 2012 and up.

    by mikefrobbins at 2012-11-02 20:49:37

    Here's where you can find the .NET framework 4.0:
    http://www.microsoft.com/en-us/download/details.aspx?id=17851

    And here's PowerShell 3.0:
    http://www.microsoft.com/en-us/download/details.aspx?id=34595

    by mikefrobbins at 2012-11-02 20:58:33

    [quote="coderaven"]What version of Windows? XP, Vista, 7?

    PowerShell 3 is only for WIndows 7/Server 2008 R2; Windows 8 / Server 2012 and up.[/quote]

    PowerShell 3 is for Windows 7 / Server 2008 (non-R2) and higher. Good catch though on asking what OS. I created some screenshots on this very subject earlier today to write a blog about this error because I've seen a lot of people running into this due to not having the .NET framework prerequisite.

    by mikefrobbins at 2012-11-03 06:33:07

    Here's the blog article I referenced in my previous post:
    http://mikefrobbins.com/2012/11/03/when-trying-to-install-powershell-version-3-0-you-receive-the-message-the-update-is-not-applicable-to-your-computer/

    by figueroa2david at 2012-11-03 20:40:41

    I wouldn't have asked on non-Windows 7 🙂

    Didn't think about the .net, but i do have .net 4, and I am still getting the error.

    I have the aforementioned MSU file.. I'm definitely stumped on it so far..

    David F.

    by figueroa2david at 2012-11-03 21:02:22

    I got it working. I tried the solution from the german translation, but that didn't work.

    It turns out that the client profile of .net 4.0 was not sufficient, I had to install the full version, and then I was able to successfully install PS v3.

    Thanks!

    David F.

You must be logged in to reply to this topic.