Powershell V6 and V5.1 coexistence

Welcome Forums General PowerShell Q&A Powershell V6 and V5.1 coexistence

Viewing 2 reply threads
  • Author
    Posts
    • #198818
      Participant
      Topics: 34
      Replies: 88
      Points: 41
      Rank: Member

      Greetings,

      We have a script server that runs loads of PS scheduled scripts using V5.1.

      Recently someone came to us with a requirement to run a script which requires PS V6.

      Can I install V6 on the script server? Will it co-exist with 5.1? Will the existing scripts run using V5.1 if V6 is installed?

      Thanks

      David

    • #198824
      Participant
      Topics: 4
      Replies: 1908
      Points: 4,259
      Helping Hand
      Rank: Community Hero

      Can I install V6 on the script server? Will it co-exist with 5.1?

      They do. They are installed in different locations. Windows Powershell : “C:\Windows\System32\WindowsPowerShell\v1.0\powershell.exe” and Powershell Core (or 6.2 or 7.0rc1 or what ever): “C:\Program Files\PowerShell\7-preview\pwsh.exe

      Will the existing scripts run using V5.1 if V6 is installed?

      Of course. You simply choose the version you need by the executable you start. 😉

    • #198827
      Participant
      Topics: 34
      Replies: 88
      Points: 41
      Rank: Member

      Can I install V6 on the script server? Will it co-exist with 5.1?

      They do. They are installed in different locations. Windows Powershell : “C:\Windows\System32\WindowsPowerShell\v1.0\powershell.exe” and Powershell Core (or 6.2 or 7.0rc1 or what ever): “C:\Program Files\PowerShell\7-preview\pwsh.exe

      Will the existing scripts run using V5.1 if V6 is installed?

      Of course. You simply choose the version you need by the executable you start. 😉

      Thanks heaps!

Viewing 2 reply threads
  • You must be logged in to reply to this topic.