PSWA with local user

Welcome Forums General PowerShell Q&A PSWA with local user

Viewing 4 reply threads
  • Author
    Posts
    • #76445
      Participant
      Topics: 5
      Replies: 16
      Points: 2
      Rank: Member

      Hey guys I’ve just registered and already coming around with a question :),

      I installed the PSWA Feature in my test evnironment.
      Installed PSWA Web Application with test certificates.
      Created a local user called “maba”.
      Added some Pswa Authorizatoin rules:
      add-PswaAuthorizationRule -username ec2amaz-bghg9hi\Administrator -computername ec2amaz-bghg9hi *
      add-PswaAuthorizationRule -username ec2amaz-bghg9hi\maba -computername ec2amaz-bghg9hi *
      When I now open the webpage https://127.0.0.1/pswa and log in with my Administrator account it works, but with the maba account it doesn’t. I try to figure out why, even if I add
      add-PswaAuthorizationRule * * *
      I’m not able to access with the maba user, Administrator works.
      The following credentials I used at https://127.0.0.1/pswa/
      user name: ec2amaz-bghg9hi\Administrator or ec2amaz-bghg9hi\maba
      password: …
      computer name: ec2amaz-bghg9hi

      best regards,
      baschi

    • #76496
      Participant
      Topics: 16
      Replies: 174
      Points: 2
      Rank: Member

      Is maba a non-admin user, or is it something like a local admin? What error are you seeing? You might take a look at https://technet.microsoft.com/en-us/library/dn282395(v=ws.11).aspx to see if your issue matches any of the ones listed.

      • #76549
        Participant
        Topics: 5
        Replies: 16
        Points: 2
        Rank: Member

        Thanks for you reply.
        Maba is a user which is part of the local Administrator Group. I got that error message:
        “Access to the destination computer has been denied. Verify that you have access to the destination Windows PowerShell session configuration. This error can also occur if Windows PowerShell remote management has been disabled on the destination Computer.”
        even when I add Wildcard in the username field of pswaautorizationrule:
        PS C:\Windows\system32> Get-PswaAuthorizationRule

        Id RuleName User Destination ConfigurationName
        — ——– —- ———– —————–
        0 Rule 0 ec2amaz-bghg9hi\maba ec2amaz-bghg9hi *
        1 Rule 1 ec2amaz-bghg9hi\maba * *

        BR Baschi

    • #76558
      Participant
      Topics: 8
      Replies: 20
      Points: 0
      Rank: Member
      • #76564
        Participant
        Topics: 5
        Replies: 16
        Points: 2
        Rank: Member

        thanks but this didn’t help. User is part of the local Admin Group.

    • #76567
      Participant
      Topics: 8
      Replies: 20
      Points: 0
      Rank: Member

      As per the Error: -This error can also occur if Windows PowerShell remote management has been disabled on the destination Computer.”

      could you check if the winrm is enabled?

      Ref for PowerShell remoting – (https://technet.microsoft.com/en-us/library/ff700227.aspx)

    • #76588
      Participant
      Topics: 16
      Replies: 174
      Points: 2
      Rank: Member

      Check out the below. It says you’ll get the error if the account is not a member of the local Remote Management Users group on the machine you’re connecting to. I don’t have my lab up, so I can’t look at my group.

      http://nikcharlebois.com/powershell-web-access-to-manage-sharepoint/

Viewing 4 reply threads
  • The topic ‘PSWA with local user’ is closed to new replies.