Pull Client failing when using community resource

Welcome Forums DSC (Desired State Configuration) Pull Client failing when using community resource

This topic contains 1 reply, has 1 voice, and was last updated by

Joe
 
Participant
3 years, 8 months ago.

  • Author
    Posts
  • #24011
    Joe

    Participant
    Points: 0
    Rank: Member

    Hi,

    I'm using the cWebAdministration module to create a DSC for a simple website. I have it working and tested it by pushing to localhost. I then proceeded to test it in the Pull Mode using a new VM and it's failing with the error below. FYI, I do not have this module installed on the Pull Client.

    Job {833F505B-DCCE-11E4-80F2-060A93EC8201} :
    This event indicates that failure happens when LCM is trying to get the configuration from pull server using download manager WebDownloadManager. ErrorId is 0x1. ErrorDetail is Cannot find module cWebAdministration_1.1.2 from the server http://192.1.1.22/PullSvc/PSDSCPullServer.svc//Module%5BConfigurationId='e86549dc-7a5f-45b6-9d66-560d980587a8',ModuleName='cWebAdministration',ModuleVersion='1.1.2']/ModuleContent.

    The error seems obvious so I tried copying the module from "C:\Program Files\WindowsPowerShell\Modules\cWebAdministration" to "C:\Program Files\WindowsPowerShell\DscService\Modules" and I still get the error. When I hit the url, I'm getting a 404, but svr is reachable on that IP.

    Any hunches? Whats the guideline for serving a DSC that uses custom resources?

  • #24012
    Joe

    Participant
    Points: 0
    Rank: Member

The topic ‘Pull Client failing when using community resource’ is closed to new replies.