Pull Server Connection Error

This topic contains 3 replies, has 3 voices, and was last updated by Profile photo of Otto Helweg Otto Helweg 2 years ago.

  • Author
    Posts
  • #20891
    Profile photo of Otto Helweg
    Otto Helweg
    Participant

    Hi Folks,

    I'm building my first PowerShell DSC pull server pilot. When trying to setup the client to perform its first pull I get the connection error below. Here's what works:

    1. From the client I have successfully pulled up the pull server URL (shows the service is responsive and listening)
    2. Established a PowerShell remoting session to the Pull Server from the client
    3. Performed 'winrm id' (authenticated and unauthenticated)
    4. Verified that the client's network interface is not set to 'public'
    5. wsman/config/client TrustedHosts="*" (but I think the successful PowerShell remoting shows that WinRM is not the issue).

    Any ideas?

    Here's the client script.

    Configuration SetPullMode 
    {
    	param([string]$guid)
    	Node cheftest
    	{
    		LocalConfigurationManager
    		{
    
    			ConfigurationMode = 'ApplyOnly'
    			ConfigurationID = $guid
    			RefreshMode = 'Pull'
    			DownloadManagerName = 'WebDownloadManager'
    			DownloadManagerCustomData = @{
    				ServerUrl = 'http://mypullserver.net:80/PSDSCPullServer.svc';
    				AllowUnsecureConnection = 'true' }
    		}
    	}
    }
    
    SetPullMode –guid $guid
    Set-DSCLocalConfigurationManager -Computer cheftest -Path ./SetPullMode –Verbose
    

    With the output:

        Directory: C:\temp\SetPullMode
    
    
    Mode                LastWriteTime     Length Name                                          
    ----                -------------     ------ ----                                          
    -a---         12/1/2014   3:30 PM       1704 cheftest.meta.mof                             
    VERBOSE: Performing the operation "Start-DscConfiguration: SendMetaConfigurationApply" on ta
    rget "MSFT_DSCLocalConfigurationManager".
    VERBOSE: Perform operation 'Invoke CimMethod' with following parameters, ''methodName' = Sen
    dMetaConfigurationApply,'className' = MSFT_DSCLocalConfigurationManager,'namespaceName' = ro
    ot/Microsoft/Windows/DesiredStateConfiguration'.
    The client cannot connect to the destination specified in the request. Verify that the 
    service on the destination is running and is accepting requests. Consult the logs and 
    documentation for the WS-Management service running on the destination, most commonly IIS 
    or WinRM. If the destination is the WinRM service, run the following command on the 
    destination to analyze and configure the WinRM service: "winrm quickconfig".
        + CategoryInfo          : ConnectionError: (root/Microsoft/...gurationManager:String)  
       [], CimException
        + FullyQualifiedErrorId : HRESULT 0x80338012
        + PSComputerName        : cheftest
     
    VERBOSE: Operation 'Invoke CimMethod' complete.
    VERBOSE: Set-DscLocalConfigurationManager finished in 8.191 seconds.
    

    BTW, this forum and 'The DSC Book' have been very very helpful! 🙂

  • #20894
    Profile photo of Don Jones
    Don Jones
    Keymaster

    DSC doesn't use Remoting, it uses WinRM – they're not the same. And Pull uses neither, it's just HTTP. What you're doing is attempting to Push a config to a node. That requires WinRM to the node. Have you enabled that on the node? Whatever machine is running your script must be abLe to connect to the specified target node.

  • #20895
    Profile photo of Dave Wyatt
    Dave Wyatt
    Moderator

    Yep, it's a winRM session to cheftest (not to the pull server) that's failing here. You can either run that configuration locally to set up the LCM, or enable WinRM (or PSRemoting; both will work) on the cheftest node.

  • #20896
    Profile photo of Otto Helweg
    Otto Helweg
    Participant

    Yup, that fixed it. WinRM was not fully running on the client (cheftest) and I was turned around thinking that WinRM was being used to communicate with the pull server rather than only being used to locally configure the client.

    Thanks for your prompt responses!

You must be logged in to reply to this topic.