Author Posts

August 6, 2015 at 6:07 am

Hi All,
I have been able to setup DSC Pull server (http) in Windows 2012R2 and it works great when I use another Windows 2012R2 system as client. That machine can pull all data and custom resources from my 2012R2 pull server.

I also need to setup same configuration for Win 2008R2 client. And I am having hard time make it work. So far, I have installed WMF 4.0 and .NET Framework 4.5 into that client. I have also ran ` winrm quickconfig ` to configure winrm on client (so listener is present and firewall exception for winrm is present too).

But now, I am getting following error,
`
The WS-Management service cannot process the request. The service cannot find the resource identified by the resource URI
and selectors.
+ CategoryInfo : ObjectNotFound: (root/Microsoft/...gurationManager:String) [], CimException
+ FullyQualifiedErrorId : HRESULT 0x80338000
+ PSComputerName : DSC2008R2
`

I am not sure what I am missing here. What resource WS-Management service can't find.
Any help is appreciated.

TIA,
Jack

August 6, 2015 at 7:32 am

Can you create a session using a normal Powershell window using enter-pssession?

Are you able to connect to the computer remotely for other management tasks such as computer management or ping the server?

Sounds like either permissions or network/ connection issue.

Maybe worth trying to create a powershell session from the 2008 R2 box to localhost. That will tell you if all the prerequisites are in place.

Karl

August 6, 2015 at 7:41 am

Thanks for reply,
Actually I can start session to this client machine from my pull server using enter-pssession. I can ping this machine too.

User that is running scripts is administrator on both machines (don't know if it matters, since LCM runs under SYSTEM account). So I don't think its permission or security issue. But can you tell me what else I need to look for if this issue is related to security or permission ?

Do I need to have PS 4 installed on 2008R2 ? This machine doesn't have it.

August 6, 2015 at 8:32 am

Jack,

Which command did you execute to get the error and from where are you running it?

August 6, 2015 at 8:39 am

I have made this configuration for 2008R2 node (ignore $guid, it's guid of mof file that I have created for 2008R2 node),

configuration setPullMode2008
{
   param ([string] $guidID)

   node DSC2008R2
   {
    LocalConfigurationManager
    {
     ConfigurationMode = 'ApplyAndAutoCorrect'
     ConfigurationID = $guidID
     RefreshMode = 'Pull'
     DownloadManagerName = 'WebDownloadManager'
     DownloadManagerCustomData = @{
     ServerUrl = 'http://dsc2012r2/PSDSCPullServer/psdscpullserver.svc';
            AllowUnsecureConnection = 'true'}
    }
   }
}

cd C:\dsc
setPullMode2008 -guidID $guid
Set-DscLocalConfigurationManager -ComputerName DSC2008R2 -Path ./setPullMode2008 -verbose

I am running this command from my Pull Server. And user under which I am running is in administrator group of both client and pull server. Also, if I run exactly same configuration script for my 2012R2 client (with different node ofcourse), then it works just fine.

August 10, 2015 at 6:27 am

Hi Alex, as I mentioned in my first post. I have it already installed before I even attempted to try DSC on Win 2008R2 box.

August 20, 2015 at 3:38 am

Hi Jack,

Sorry got confused when you said "Do I need to have PS 4 installed on 2008R2 ? This machine doesn't have it." I thought that this would be installed when you installed WMF4?

Whats the return when you run Get-DscLocalConfigurationManager?