RDS Settings for "Default to main client printer"

This topic contains 0 replies, has 1 voice, and was last updated by  Forums Archives 5 years, 11 months ago.

  • Author
    Posts
  • #5311

    by Yonderbox at 2012-11-28 10:47:11

    I'm configuring RDS settings on Windows Server 2008 R2, using the RemoteDesktopServices module in Powershell 2.0.
    I'm able to set everything except for disabling "Default to main client printer" redirection in Client Settings for RDP-tcp.
    There doesn't seem to be a reference to it in RDS:\rdsconfiguration\connections\rdp-tcp\RedirectionSettings.
    I've configured it in the GUI, piped the settings to a file (in PS), changed the GUI settings, captured that, and compared them – no difference found.
    I'm just wondering if anyone has set this successfully.

    by mikefrobbins at 2012-11-28 21:07:23

    From what I can see, the ability to change that particular setting doesn't exist when trying to set it via the RDS PSProvider:
    a user uploaded image

    I started to say that it couldn't be done in PowerShell, but that would just mean that I hadn't figured it out yet.

    You can set it through the registry:
    Set-ItemProperty -Path "HKLM:\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp" -Name fForceClientLptDef -Value 0
    a user uploaded image

    1 in the registry is unchecked and 0 is checked. Checked and unchecked references what the setting looks like in the GUI. Make sure you do a "refresh" in the GUI for the setting change to show up. Simply closing and reopening the RDP-Tcp properties window doesn't refresh it (took me a while to figure that out).

    by Yonderbox at 2012-12-03 09:26:15

    Great!
    Thanks, Mike. MS has this weird habit of leaving little things dangling with scripting RDS.
    The aim, for me, is to keep it all under the Powershell umbrella and the suggestion for diddling the registry was great.
    It's interesting that 1=unchecked and 0=checked – it dovetails with the settings' purpose (disabling redirection for a thing), but is at odds with what you might expect.

You must be logged in to reply to this topic.